summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus Fillipe2022-10-23 17:19:14 -0300
committerMatheus Fillipe2022-10-23 17:19:14 -0300
commit604b59282cd6696f799b0bab3e00a869482de233 (patch)
treed4bbc7632c26c7ee6108fdfbbf6a81a522f9d6f5
parent7306fde2f9cccc03f354521de679e1be478e674f (diff)
downloadaur-604b59282cd6696f799b0bab3e00a869482de233.tar.gz
Package recreation
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD42
-rw-r--r--warpd.service10
3 files changed, 33 insertions, 40 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0e5b4ab8a4c8..5bd4a79df03a 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,19 +1,18 @@
-pkgbase = warpd
- pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio
- pkgver = 0.9a
+pkgbase = warpd-git
+ pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen.
+ pkgver = r229.faa423d
pkgrel = 1
url = https://github.com/rvaiya/warpd
arch = x86_64
- license = GPLV3
+ license = MIT
makedepends = git
- makedepends = make
- makedepends = libxinerama
- makedepends = libxft
- makedepends = libxfixes
- makedepends = libxtst
- makedepends = libx11
+ depends = libxinerama
+ depends = libxft
+ depends = libxfixes
+ depends = libxtst
+ depends = libx11
provides = warpd
source = git+https://github.com/rvaiya/warpd
md5sums = SKIP
-pkgname = warpd
+pkgname = warpd-git
diff --git a/PKGBUILD b/PKGBUILD
index 105fed422a01..f51a07520b5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,29 +1,33 @@
-# Maintainer dpetrov <petrov.dimp@gmail.com>
+# Maintainer mattf <matheusfillipeag@gmail.com>
-pkgname=warpd
+pkgname=warpd-git
+pkgver=r229.faa423d
_gitname=warpd
-pkgver=0.9a
pkgrel=1
-pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio"
+pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen."
url="https://github.com/rvaiya/warpd"
-license=('GPLV3')
+license=('MIT')
arch=('x86_64')
md5sums=('SKIP')
-depends=()
-conflicts=()
-makedepends=(git make libxinerama libxft libxfixes libxtst libx11)
+makedepends=(git)
+depends=(libxinerama libxft libxfixes libxtst libx11)
provides=(warpd)
source=("git+$url")
-package() {
- cd ${_gitname}
- pwd
- ls -altr
- make
- # make DESTDIR="{pkgdir}" install
- # echo "${pkgdir}"
- # echo "${_gitname}"
- # ls -altr
- install -Dm755 -t "${pkgdir}"/usr/bin bin/warpd
- install -Dm644 -t "${pkgdir}"/usr/lib/systemd/user ../../warpd.service
+pkgver() {
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+
+build () {
+ cd ${_gitname}
+ make
+}
+
+package () {
+ cd ${_gitname}
+ install -Dm755 -t "${pkgdir}"/usr/bin bin/warpd
+ mkdir -p "${pkgdir}"/usr/share/man/man1/
+ install -Dm644 -t "${pkgdir}"/usr/share/man/man1/ usr/local/share/man/man1/warpd.1.gz
+}
+md5sums=('SKIP')
diff --git a/warpd.service b/warpd.service
deleted file mode 100644
index 39630bc97a9f..000000000000
--- a/warpd.service
+++ /dev/null
@@ -1,10 +0,0 @@
-[Unit]
-Description=Service for managing warpd
-After=display-manager.service
-
-[Service]
-ExecStart=/usr/bin/warpd -f
-Restart=always
-
-[Install]
-WantedBy=default.target \ No newline at end of file