summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus Fillipe2022-11-05 22:14:41 -0300
committerMatheus Fillipe2022-11-05 22:14:41 -0300
commit8f303b334e3656f1d72d367ed3ecce61089522c2 (patch)
tree0ad127b6cc4fe416f285d2f2777038d1cb1d577b
parentc4f77e9cae58189b372c459542a66fed431b9426 (diff)
downloadaur-8f303b334e3656f1d72d367ed3ecce61089522c2.tar.gz
Remove doc building
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD10
2 files changed, 8 insertions, 6 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0a6502ea5041..5e0a3f082f44 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,12 +6,14 @@ pkgbase = warpd-git
arch = x86_64
license = MIT
makedepends = git
- makedepends = scdoc
depends = libxinerama
depends = libxft
depends = libxfixes
depends = libxtst
depends = libx11
+ depends = libxkbcommon
+ depends = cairo
+ optdepends = wayland: wayland support
provides = warpd
conflicts = warpd
conflicts = warpd-wayland
diff --git a/PKGBUILD b/PKGBUILD
index e6c9b22ea5c6..25b27a6269bd 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer mattf <matheusfillipeag@gmail.com>
pkgname=warpd-git
-pkgver=r234.5971cfb
+pkgver=r238.6ece9f2
_gitname=warpd
pkgrel=1
pkgdesc="A modal keyboard driven interface for mouse manipulation."
@@ -9,8 +9,9 @@ url="https://github.com/rvaiya/warpd"
license=('MIT')
arch=('x86_64')
md5sums=('SKIP')
-makedepends=(git scdoc)
-depends=(libxinerama libxft libxfixes libxtst libx11)
+makedepends=(git)
+depends=(libxinerama libxft libxfixes libxtst libx11 libxkbcommon cairo)
+optdepends=('wayland: wayland support')
provides=(warpd)
conflicts=(warpd warpd-wayland warpd-wayland-git)
source=("git+$url")
@@ -23,10 +24,9 @@ pkgver() {
build () {
cd ${_gitname}
make
- make man
}
package () {
cd ${_gitname}
- make install DESTDIR="$pkgdir"
+ make install DESTDIR="$pkgdir" PREFIX="/usr"
}