summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authormatheusfillipe2021-12-15 15:39:22 -0300
committermatheusfillipe2021-12-15 15:39:22 -0300
commitdc6e0204ca4c5065a1c6b02a9d634fd567025bbc (patch)
tree15f1d580d1a25616098b4209651228cc85113e54
parent936b60d6e44f420a015db0d3825904e092768c22 (diff)
downloadaur-dc6e0204ca4c5065a1c6b02a9d634fd567025bbc.tar.gz
Created a proper PKGBUILD
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD29
2 files changed, 25 insertions, 22 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ea279af5ce82..8ed4e136ff0b 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,20 +1,18 @@
pkgbase = warpd-git
- pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio
- pkgver = 0.9a
+ pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen.
+ pkgver = r73.f7d1202
pkgrel = 1
url = https://github.com/rvaiya/warpd
arch = x86_64
- license = GPLV3
+ license = MIT
makedepends = git
- makedepends = make
- makedepends = libxinerama
- makedepends = libxft
- makedepends = libxfixes
- makedepends = libxtst
- makedepends = libx11
+ depends = libxinerama
+ depends = libxft
+ depends = libxfixes
+ depends = libxtst
+ depends = libx11
provides = warpd
source = git+https://github.com/rvaiya/warpd
md5sums = SKIP
pkgname = warpd-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 109ec757cf03..dd6d49311a65 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,25 +1,30 @@
# Maintainer mattf <matheusfillipeag@gmail.com>
-pkgbase=warpd-git
pkgname=warpd-git
-pkgver=0.9a
+pkgver=r73.f7d1202
+_gitname=warpd
pkgrel=1
-pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen. The program was inspired by the mousekeys feature of Kaleidoscope, the firmware for the Keyboardio"
+pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen."
url="https://github.com/rvaiya/warpd"
-license=('GPLV3')
+license=('MIT')
arch=('x86_64')
md5sums=('SKIP')
-depends=()
-conflicts=()
-makedepends=(git make libxinerama libxft libxfixes libxtst libx11)
+makedepends=(git)
+depends=(libxinerama libxft libxfixes libxtst libx11)
provides=(warpd)
source=("git+$url")
-package() {
- cd warpd
- make
+pkgver() {
+ cd ${_gitname}
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+build () {
+ cd ${_gitname}
+ make
+}
-
-#vim: syntax=sh
+package () {
+ cd ${_gitname}
+ make install
+}