summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatheus Fillipe2022-10-23 18:07:26 -0300
committerMatheus Fillipe2022-10-23 18:07:26 -0300
commit7700b3198e098f45d4a294bbf6d879d26605d599 (patch)
tree9b338a29ff08394922cf3767f8ece5bbd14ac482
downloadaur-7700b3198e098f45d4a294bbf6d879d26605d599.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD32
2 files changed, 51 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..9d315217ed40
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = warpd-wayland
+ pkgdesc = A small X program which facilitates recursively warping the pointer to different quadrants on the screen.
+ pkgver = v1.3.3
+ pkgrel = 1
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ depends = wayland
+ depends = libxkbcommon
+ depends = cairo
+ provides = warpd
+ conflicts = warpd-git
+ conflicts = warpd
+ conflicts = warpd-wayland-git
+ options = !buildflags
+ source = warpd-wayland.tar.gz::https://github.com/rvaiya/warpd/archive/refs/tags/v1.3.3.zip
+ md5sums = c98c0ff317384cb451a38a34b202ef3a
+
+pkgname = warpd-wayland
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9ecc0ae83284
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer mattf <matheusfillipeag@gmail.com>
+
+pkgname=warpd-wayland
+pkgver=v1.3.3
+_gitname=warpd
+pkgrel=1
+pkgdesc="A small X program which facilitates recursively warping the pointer to different quadrants on the screen."
+license=('MIT')
+arch=('x86_64')
+makedepends=(git)
+conflicts=(warpd-git warpd warpd-wayland-git)
+depends=(wayland libxkbcommon cairo)
+provides=(warpd)
+source=(
+ "${pkgname}.tar.gz::https://github.com/rvaiya/warpd/archive/refs/tags/${pkgver}.zip"
+)
+
+options=("!buildflags")
+md5sums=('c98c0ff317384cb451a38a34b202ef3a')
+
+build () {
+ cd "${pkgname}-${pkgver/v/}"
+ make
+}
+
+package () {
+ cd "${pkgname}-${pkgver/v/}"
+ install -Dm755 -t "${pkgdir}"/usr/bin bin/warpd
+ mkdir -p "${pkgdir}"/usr/share/man/man1/
+ # install -Dm644 -t "${pkgdir}"/usr/share/man/man1/ usr/local/share/man/man1/warpd.1.gz
+ install -Dm644 -t "${pkgdir}"/usr/share/man/man1/ warpd.1.gz
+}