summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2020-03-01 19:29:10 -0500
committerKyle Laker2020-03-01 19:29:10 -0500
commit377127e6a87ed33026e31f067631ac45bde951ae (patch)
tree39aca926276b1fe61775cd5b4023bf1c1b2c8e63
parent772ce1bd5bb7c5abc1dde36bf44c77436ec6c621 (diff)
downloadaur-377127e6a87ed33026e31f067631ac45bde951ae.tar.gz
Update name to warpinator
-rw-r--r--.SRCINFO11
-rw-r--r--PKGBUILD13
2 files changed, 17 insertions, 7 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 3465cf8bef44..0fbf66d0c8de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,4 +1,4 @@
-pkgbase = lm-warp-git
+pkgbase = warpinator
pkgdesc = Share files across the LAN by Linux Mint
pkgver = r39.53989e7
pkgrel = 1
@@ -12,10 +12,13 @@ pkgbase = lm-warp-git
depends = python-zeroconf
depends = python-xapp
depends = xapps
- provides = lm-warp
- conflicts = lm-warp
+ provides = warpinator
+ conflicts = warpinator
+ conflicts = haskell-wai-app-static
+ conflicts = lm-warp-git
+ conflicts = warp-git
source = git+https://github.com/linuxmint/warp.git
sha512sums = SKIP
-pkgname = lm-warp-git
+pkgname = warpinator
diff --git a/PKGBUILD b/PKGBUILD
index 0d27db22d93f..afb8b34c434a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Kyle Laker <kyle@laker.email>
# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
-pkgname=lm-warp-git
+pkgname=warpinator
pkgver=r39.53989e7
pkgrel=1
pkgdesc="Share files across the LAN by Linux Mint"
@@ -13,7 +13,7 @@ license=("GPL")
depends=("pygobject-devel" "python-setproctitle" "python-zeroconf" "python-xapp" "xapps")
makedepends=("git" "meson")
provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}")
+conflicts=("${pkgname%-git}" "haskell-wai-app-static" "lm-warp-git" "warp-git")
source=("git+${url}.git")
sha512sums=('SKIP')
@@ -22,8 +22,15 @@ pkgver() {
printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
}
+prepare() {
+ cd "$srcdir/warp"
+
+ # Fix hard-coded libexec dir in main warp script
+ sed -i 's/libexec/lib/g' bin/warp
+}
+
build() {
- meson --prefix /usr --buildtype=plain warp build
+ arch-meson warp build
ninja -C build
}