summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKyle Laker2020-02-13 19:52:27 -0500
committerKyle Laker2020-02-13 19:52:27 -0500
commit96550a61fe51b2e96745c469f156e1731940c5bb (patch)
tree39c728006fb8ee63edbde5fec359e76cd66acbf9
downloadaur-96550a61fe51b2e96745c469f156e1731940c5bb.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD25
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..ef96133298f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = lm-warp-git
+ pkgdesc = Share files across the LAN
+ pkgver = 0.0.1
+ pkgrel = 1
+ url = https://github.com/linuxmint/warp
+ arch = x86_64
+ license = MIT
+ makedepends = git
+ makedepends = meson
+ depends = pygobject-devel
+ depends = python-setproctitle
+ depends = python-zeroconf
+ source = lm-warp-git::git://github.com/linuxmint/warp/
+ sha512sums = SKIP
+
+pkgname = lm-warp-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ea8988f0596a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer: Kyle Laker <kyle@laker.email>
+
+pkgname=lm-warp-git
+pkgver=0.0.1
+pkgrel=1
+pkgdesc="Share files across the LAN"
+arch=("x86_64")
+_github="github.com/linuxmint/warp"
+url="https://$_github"
+license=(MIT)
+depends=(pygobject-devel python-setproctitle python-zeroconf)
+makedepends=(git meson)
+source=("$pkgname::git://$_github/")
+sha512sums=('SKIP')
+
+build() {
+ cd "$srcdir"
+ pwd
+ meson --prefix /usr --buildtype=plain "$pkgname" build
+ ninja -C build
+}
+
+package() {
+ DESTDIR="$pkgdir" ninja -C build install
+}