summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorSam Burgos2020-05-04 18:25:09 -0600
committerSam Burgos2020-05-04 18:25:09 -0600
commitd359daafa29180523b3564f8ba1ddeb520890883 (patch)
tree08af6c8923ab4bfe450bb6d804fddf0fddb726f2
parent377127e6a87ed33026e31f067631ac45bde951ae (diff)
downloadaur-d359daafa29180523b3564f8ba1ddeb520890883.tar.gz
added warpinator and updated non-git version to 1.0.1
-rw-r--r--.SRCINFO21
-rw-r--r--PKGBUILD64
2 files changed, 56 insertions, 29 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 0fbf66d0c8de..29b146051dfd 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,24 +1,27 @@
pkgbase = warpinator
pkgdesc = Share files across the LAN by Linux Mint
- pkgver = r39.53989e7
+ pkgver = 1.0.1
pkgrel = 1
- url = https://github.com/linuxmint/warp
+ url = http://packages.linuxmint.com/pool/main/w/warpinator
arch = x86_64
license = GPL
- makedepends = git
+ makedepends = gobject-introspection
makedepends = meson
+ makedepends = python-grpcio-tools
+ depends = grpc
depends = pygobject-devel
+ depends = python-grpcio
depends = python-setproctitle
- depends = python-zeroconf
depends = python-xapp
+ depends = python-zeroconf
depends = xapps
- provides = warpinator
- conflicts = warpinator
- conflicts = haskell-wai-app-static
+ optdepends = gufw: Configure firewall rules
+ conflicts = lm-warp
conflicts = lm-warp-git
+ conflicts = warpinator-git
conflicts = warp-git
- source = git+https://github.com/linuxmint/warp.git
- sha512sums = SKIP
+ source = warpinator_1.0.1.tar.xz::http://packages.linuxmint.com/pool/main/w/warpinator/warpinator_1.0.1.tar.xz
+ sha256sums = ad6566a42bdbbcd4039778c8306b1322b161a5e6a382fbc4cf7e9e18d7130500
pkgname = warpinator
diff --git a/PKGBUILD b/PKGBUILD
index afb8b34c434a..af283c6d9e74 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,32 +1,56 @@
-# Maintainer: Kyle Laker <kyle@laker.email>
-# Contributor: Mark Wagie <mark dot wagie at tutanota dot com>
+# Maintainer: Sam Burgos <santiago.burgos1089@gmail.com>
+
pkgname=warpinator
-pkgver=r39.53989e7
+pkgver=1.0.1
pkgrel=1
pkgdesc="Share files across the LAN by Linux Mint"
arch=("x86_64")
-url="https://github.com/linuxmint/warp"
-# License file is missing from the root of the repository; however, GPL-2+ is given in the
-# debian/control file: https://github.com/linuxmint/warp/blob/master/debian/copyright
+url="http://packages.linuxmint.com/pool/main/w/${pkgname}"
license=("GPL")
-depends=("pygobject-devel" "python-setproctitle" "python-zeroconf" "python-xapp" "xapps")
-makedepends=("git" "meson")
-provides=("${pkgname%-git}")
-conflicts=("${pkgname%-git}" "haskell-wai-app-static" "lm-warp-git" "warp-git")
-source=("git+${url}.git")
-sha512sums=('SKIP')
-
-pkgver() {
- cd "$srcdir/warp"
- printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
-}
+depends=(
+ gtk3
+ python-cryptography
+ python-gobject
+ python-grpcio
+ python-protobuf
+ python-pynacl
+ python-setproctitle
+ python-xapp
+ python-zeroconf
+ xapps
+)
+depends=(
+ grpc
+ pygobject-devel
+ python-grpcio
+ python-setproctitle
+ python-xapp
+ python-zeroconf
+ xapps
+)
+makedepends=(
+ gobject-introspection
+ meson
+ python-grpcio-tools
+)
+optdepends=('gufw: Configure firewall rules')
+conflicts=(
+ lm-warp
+ lm-warp-git
+ warpinator-git
+ warp-git
+)
+source=("${pkgname}_${pkgver}.tar.xz::${url}/${pkgname}_${pkgver}.tar.xz")
+sha256sums=('ad6566a42bdbbcd4039778c8306b1322b161a5e6a382fbc4cf7e9e18d7130500')
prepare() {
- cd "$srcdir/warp"
+ cd "$srcdir/warp"
- # Fix hard-coded libexec dir in main warp script
- sed -i 's/libexec/lib/g' bin/warp
+ # Fix hard-coded libexec dir
+ sed -i 's/libexec/lib/g' \
+ "bin/warpinator" \
+ install-scripts/meson_generate_and_install_protobuf_files.py
}
build() {