summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortioguda2019-07-13 08:21:39 -0300
committertioguda2019-07-13 08:21:39 -0300
commit9230417a92d8eb12418304d9db151577a092a175 (patch)
treeec4ca609822a6e27397d50ce171a5669cab0ae80
parent2dfaa7d9ea8aefa66d564b7a0655f14120f34f66 (diff)
downloadaur-9230417a92d8eb12418304d9db151577a092a175.tar.gz
Fix warsaw-service
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
-rw-r--r--fix.patch21
3 files changed, 28 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d8603ef4b383..e0565fcba5fc 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = warsaw-bin
pkgdesc = Banking security tool developed by GAS Tecnologia
pkgver = 1.13.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://www.dieboldnixdorf.com.br/warsaw
install = warsaw-bin.install
arch = i686
@@ -27,6 +27,8 @@ pkgbase = warsaw-bin
backup = etc/init.d/warsaw
backup = etc/init/warsaw.conf
backup = etc/xdg/autostart/warsaw.desktop
+ source = fix.patch
+ sha256sums = cf2389806c92ac87d7775522d6dbc7de63a52f780dbe2b8e40a6e248709414a5
source_i686 = https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw_setup_32.deb
sha256sums_i686 = a6f6ec95ccd023aef66f8a80c8695bfe8713a68435b3e277b9e5a6b3b0c818af
source_x86_64 = https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw_setup_64.deb
diff --git a/PKGBUILD b/PKGBUILD
index 6d14a54a3a32..be8142d663eb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=warsaw-bin
pkgver=1.13.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Banking security tool developed by GAS Tecnologia"
arch=(i686 x86_64)
url="https://www.dieboldnixdorf.com.br/warsaw"
@@ -14,13 +14,16 @@ options=('!strip')
install=${pkgname}.install
conflicts=('warsaw')
provides=('warsaw')
+source=('fix.patch')
source_i686=(https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw_setup_32.deb)
source_x86_64=(https://cloud.gastecnologia.com.br/gas/diagnostico/warsaw_setup_64.deb)
+sha256sums=('cf2389806c92ac87d7775522d6dbc7de63a52f780dbe2b8e40a6e248709414a5')
sha256sums_i686=('a6f6ec95ccd023aef66f8a80c8695bfe8713a68435b3e277b9e5a6b3b0c818af')
sha256sums_x86_64=('6b99554976c12f6290c4eef97895e36bc980011703ddfbade5ff8cf825d25e58')
prepare() {
tar -xJf data.tar.xz
+ patch -p1 -i ./fix.patch
}
package() {
diff --git a/fix.patch b/fix.patch
new file mode 100644
index 000000000000..c15a15be1d00
--- /dev/null
+++ b/fix.patch
@@ -0,0 +1,21 @@
+diff --git a/lib/systemd/system/warsaw.service b/lib/systemd/system/warsaw.service
+index e84e7fb..8def1e4 100644
+--- a/lib/systemd/system/warsaw.service
++++ b/lib/systemd/system/warsaw.service
+@@ -1,11 +1,13 @@
+ [Unit]
+ Description=Warsaw Desktop
+-After=network.target auditd.service
++After=network.target
++After=auditd.service
+
+ [Service]
+-ExecStart=/usr/bin/warsaw start
+-RemainAfterExit=yes
+ Type=oneshot
++RemainAfterExit=yes
++ExecStart=/usr/bin/warsaw start
++ExecStop=/usr/bin/warsaw stop
+
+ [Install]
+ WantedBy=multi-user.target