summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortioguda2021-04-21 23:35:39 -0300
committertioguda2021-04-21 23:35:39 -0300
commitea0945391b67feb7ba1ca1e6794caad1ae66bd32 (patch)
treedb413947c1f91e239c7f07ff8ec617d0cd664c20
parent45ad0f75841310a95b7c169ad79cf32942fa4cbd (diff)
downloadaur-ea0945391b67feb7ba1ca1e6794caad1ae66bd32.tar.gz
Re-add gtk2 as optional dependency
-rw-r--r--.SRCINFO1
-rw-r--r--PKGBUILD3
-rw-r--r--warsaw-bin.install68
3 files changed, 37 insertions, 35 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 060d306e2000..9fd7dae698fe 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -11,6 +11,7 @@ pkgbase = warsaw-bin
depends = procps-ng
depends = python
depends = zenity
+ optdepends = gtk2: required on first bank setup
optdepends = python-gpgme
provides = warsaw
conflicts = warsaw
diff --git a/PKGBUILD b/PKGBUILD
index 60c898c01a24..6d5f2c8421e1 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -9,7 +9,8 @@ arch=(i686 x86_64)
url="https://diagnostico.gasantifraud.com"
license=('custom')
depends=('dbus' 'procps-ng' 'python' 'zenity')
-optdepends=('python-gpgme')
+optdepends=('gtk2: required on first bank setup'
+ 'python-gpgme')
backup=('etc/init.d/warsaw' 'etc/init/warsaw.conf')
options=('!strip' '!emptydirs')
install=${pkgname}.install
diff --git a/warsaw-bin.install b/warsaw-bin.install
index d6449086f082..233897c8e00e 100644
--- a/warsaw-bin.install
+++ b/warsaw-bin.install
@@ -1,43 +1,43 @@
post_install() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
- echo -e "\e[34;1m==>\e[39;1m To use Warsaw, start its service using: \e[0m"
- echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl start warsaw \e[0m"
- echo -e "\e[34;1m==>\e[39;1m To start Warsaw at system startup, use the command: \e[0m"
- echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl enable warsaw \e[0m"
- echo -e "\e[34;1m==>\e[39;1m Complete your bank setup on the website below: \e[0m"
- echo -e "\e[34;1m==>\e[39;1m https://diagnostico.gasantifraud.com \e[0m"
-
- update-desktop-database -q
+ if [ -e "/usr/share/hunspell/pt_BR.dic" ]
+ then
+ echo -e "\e[34;1m==>\e[39;1m Para usar o Warsaw, inicie seu serviço com: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl start warsaw \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m Para iniciar o Warsaw na inicialização do sistema, utilize o comando: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl enable warsaw \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m Conclua a configuração do seu banco no site abaixo: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m https://diagnostico.gasantifraud.com \e[0m"
+ else
+ echo -e "\e[34;1m==>\e[39;1m To use Warsaw, start its service using: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl start warsaw \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m To start Warsaw at system startup, use the command: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m $ sudo systemctl enable warsaw \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m Complete your bank setup on the website below: \e[0m"
+ echo -e "\e[34;1m==>\e[39;1m https://diagnostico.gasantifraud.com \e[0m"
+ fi
}
pre_remove() {
-
- if command -v systemctl > /dev/null 2>&1; then
- systemctl stop warsaw.service
- fi
-
- if command -v warsaw > /dev/null 2>&1; then
- warsaw stop
- fi
-
- if command -v systemctl > /dev/null 2>&1; then
- systemctl disable warsaw.service
- systemctl daemon-reload
- fi
-
+ if command -v systemctl > /dev/null 2>&1; then
+ systemctl stop warsaw.service
+ fi
+
+ if command -v warsaw > /dev/null 2>&1; then
+ warsaw stop
+ fi
+
+ if command -v systemctl > /dev/null 2>&1; then
+ systemctl disable warsaw.service
+ systemctl daemon-reload
+ fi
}
post_remove() {
- gtk-update-icon-cache -q -t -f usr/share/icons/hicolor
-
- if command -v rm > /dev/null 2>&1; then
- rm -rf /usr/local/etc/warsaw
- fi
-
- if command -v pkill > /dev/null 2>&1; then
- pkill wsatspi
- fi
+ if command -v rm > /dev/null 2>&1; then
+ rm -rf /usr/local/etc/warsaw
+ fi
- update-desktop-database -q
+ if command -v pkill > /dev/null 2>&1; then
+ pkill wsatspi
+ fi
}