summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Goncharov2019-02-13 02:04:30 +0300
committerKirill Goncharov2019-02-13 02:12:48 +0300
commit6659b483e7f34c7abbf6843161e5f929338f800d (patch)
treec8da70bd6768b41f56004c15953da92b19ee2a84
parent4de3a7561f2a7fb50bf4df1b7301d5efa36daeb3 (diff)
downloadaur-6659b483e7f34c7abbf6843161e5f929338f800d.tar.gz
Use files from deb package
-rw-r--r--.SRCINFO13
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD28
-rw-r--r--wasabi.desktop9
-rw-r--r--wasabi.pngbin18352 -> 0 bytes
5 files changed, 19 insertions, 32 deletions
diff --git a/.SRCINFO b/.SRCINFO
index d7cb94a01438..5d153ccde68f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,26 +1,23 @@
pkgbase = wasabi-wallet-bin
pkgdesc = Privacy focused, ZeroLink compliant Bitcoin wallet
pkgver = 1.1.1
- pkgrel = 1
+ pkgrel = 2
url = https://wasabiwallet.io/
arch = x86_64
license = MIT
depends = curl
depends = fontconfig
+ depends = hicolor-icon-theme
provides = wasabi-wallet
conflicts = wasabi-wallet
options = !strip
options = staticlibs
- source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.1.1/WasabiLinux-1.1.1.tar.gz
- source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.1.1/WasabiLinux-1.1.1.tar.gz.asc
- source = wasabi.desktop
- source = wasabi.png
+ source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.1.1/Wasabi-1.1.1.deb
+ source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.1.1/Wasabi-1.1.1.deb.asc
source = LICENSE.md
validpgpkeys = 21D7CA45565DBCCEBE45115DB4B72266C47E075E
- sha256sums = 5ed68d9c3946cc2e7d27d24a22b694ec3b25551dd262d46cb4817ebf45e76b3d
+ sha256sums = eecbb0cf17826c5a1174102b24cfc32f0c9f5efe07f1e62a1ab217e6c38a25f1
sha256sums = SKIP
- sha256sums = 4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee
- sha256sums = 861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3
sha256sums = 986ee8b1139dbe8405801baf1081d075b53728fd5c57dd31885cf4ddbe5d8f68
pkgname = wasabi-wallet-bin
diff --git a/.gitignore b/.gitignore
index ed9fa3dcdcc2..314ad7a58533 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,3 +1,4 @@
src
pkg
*.tar.*
+*.deb*
diff --git a/PKGBUILD b/PKGBUILD
index caf88276ab66..d66759139808 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,40 +2,38 @@
pkgname=wasabi-wallet-bin
_pkgname=wasabi-wallet
pkgver=1.1.1
-pkgrel=1
+pkgrel=2
pkgdesc="Privacy focused, ZeroLink compliant Bitcoin wallet"
arch=('x86_64')
options=(!strip staticlibs)
url="https://wasabiwallet.io/"
license=('MIT')
-depends=('curl' 'fontconfig')
+depends=('curl' 'fontconfig' 'hicolor-icon-theme')
provides=('wasabi-wallet')
conflicts=('wasabi-wallet')
source=(
- "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz"
- "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz.asc"
- "wasabi.desktop"
- "wasabi.png"
+ "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/Wasabi-${pkgver}.deb"
+ "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/Wasabi-${pkgver}.deb.asc"
"LICENSE.md"
)
-sha256sums=('5ed68d9c3946cc2e7d27d24a22b694ec3b25551dd262d46cb4817ebf45e76b3d'
+sha256sums=('eecbb0cf17826c5a1174102b24cfc32f0c9f5efe07f1e62a1ab217e6c38a25f1'
'SKIP'
- '4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee'
- '861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3'
'986ee8b1139dbe8405801baf1081d075b53728fd5c57dd31885cf4ddbe5d8f68')
# Run gpg --keyserver pool.sks-keyservers.net --recv-keys B4B72266C47E075E
validpgpkeys=('21D7CA45565DBCCEBE45115DB4B72266C47E075E')
package() {
+ tar -xf "${srcdir}/data.tar.xz" -C "${pkgdir}"
+ chown -R root:root "${pkgdir}/usr/"
+ chmod -R go-w "${pkgdir}/usr/"
+
install -d -m755 "${pkgdir}/opt/"
- cp -a "$srcdir/WasabiLinux-${pkgver}" "${pkgdir}/opt/${_pkgname}"
- chown -R root:root "$pkgdir/opt/${_pkgname}"
+ cp -r "${pkgdir}/usr/local/bin/wasabiwallet/" "${pkgdir}/opt/${_pkgname}"
+ rm -r "${pkgdir}/usr/local/"
+
install -d -m755 "${pkgdir}/usr/bin/"
+ ln -s "/opt/${_pkgname}/wassabee" "${pkgdir}/usr/bin/wassabee"
ln -s "/opt/${_pkgname}/wassabee" "${pkgdir}/usr/bin/${_pkgname}"
- # Install desktop launcher.
- install -Dm644 wasabi.desktop "${pkgdir}/usr/share/applications/wasabi.desktop"
- install -Dm644 wasabi.png "${pkgdir}/usr/share/pixmaps/wasabi.png"
-
install -Dm644 "${srcdir}/LICENSE.md" -t "${pkgdir}/usr/share/licenses/${pkgname}/"
}
diff --git a/wasabi.desktop b/wasabi.desktop
deleted file mode 100644
index cf3af5fb0cd5..000000000000
--- a/wasabi.desktop
+++ /dev/null
@@ -1,9 +0,0 @@
-[Desktop Entry]
-Name=Wasabi
-GenericName=Bitcoin Wallet
-Comment=Privacy focused Bitcoin wallet, that implements trustless coin shuffling with mathematically provable anonymity
-Exec=wasabi-wallet
-Icon=wasabi
-Terminal=false
-Type=Application
-Categories=Utility;Finance;
diff --git a/wasabi.png b/wasabi.png
deleted file mode 100644
index 89929246ef54..000000000000
--- a/wasabi.png
+++ /dev/null
Binary files differ