summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDavid Parrish2019-01-06 19:53:53 -0500
committerDavid Parrish2019-01-06 19:55:12 -0500
commit6e1801715c0fccf1fa9ee92c70c342dec5e66ab9 (patch)
treead41a75be30d0d4459d14ff3a1ba1af9ed6407b8
parentc8bf81cdfd4b6029874677fd60b99ef3eb9fb063 (diff)
downloadaur-6e1801715c0fccf1fa9ee92c70c342dec5e66ab9.tar.gz
Add desktop launcher
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD12
-rw-r--r--wasabi.desktop9
-rw-r--r--wasabi.pngbin0 -> 18352 bytes
4 files changed, 24 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index cd2e86958850..4cd20d29a624 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wasabi-wallet-bin
pkgdesc = Privacy focused, ZeroLink compliant Bitcoin wallet
pkgver = 1.0.5
- pkgrel = 1
+ pkgrel = 2
url = https://wasabiwallet.io/
arch = x86_64
license = MIT
@@ -11,9 +11,13 @@ pkgbase = wasabi-wallet-bin
options = staticlibs
source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.0.5/WasabiLinux-1.0.5.tar.gz
source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.0.5/WasabiLinux-1.0.5.tar.gz.asc
+ source = wasabi.desktop
+ source = wasabi.png
validpgpkeys = 21D7CA45565DBCCEBE45115DB4B72266C47E075E
sha256sums = c1d3ef22541a4565a9cc790daa90e550041d767cb9771abaea6399bb9a5d2f0c
sha256sums = SKIP
+ sha256sums = 4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee
+ sha256sums = 861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3
pkgname = wasabi-wallet-bin
diff --git a/PKGBUILD b/PKGBUILD
index ed9e88d176a7..8ebbc19789af 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,7 +2,7 @@
pkgname=wasabi-wallet-bin
_pkgname=wasabi-wallet
pkgver=1.0.5
-pkgrel=1
+pkgrel=2
pkgdesc="Privacy focused, ZeroLink compliant Bitcoin wallet"
arch=('x86_64')
options=(!strip staticlibs)
@@ -13,9 +13,13 @@ conflicts=('wasabi-wallet')
source=(
"https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz"
"https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz.asc"
+ "wasabi.desktop"
+ "wasabi.png"
)
sha256sums=('c1d3ef22541a4565a9cc790daa90e550041d767cb9771abaea6399bb9a5d2f0c'
- 'SKIP')
+ 'SKIP'
+ '4d633e1b310eb2666e314b39a336031facd164f227a2ad595e8a0b8ba4b962ee'
+ '861064b9019ac8d0294d46c298dd2f552e078dc2d0f2b52ffb1e9e09a20278a3')
# Run gpg --keyserver pool.sks-keyservers.net --recv-keys B4B72266C47E075E
validpgpkeys=('21D7CA45565DBCCEBE45115DB4B72266C47E075E')
@@ -25,4 +29,8 @@ package() {
chown -R root:root "$pkgdir/opt/${_pkgname}"
install -d -m755 "${pkgdir}/usr/bin/"
ln -s "/opt/${_pkgname}/wassabee" "${pkgdir}/usr/bin/${_pkgname}"
+
+ # Install desktop launcher.
+ install -Dm644 wasabi.desktop "${pkgdir}/usr/share/applications/wasabi.desktop"
+ install -Dm644 wasabi.png "${pkgdir}/usr/share/pixmaps/wasabi.png"
}
diff --git a/wasabi.desktop b/wasabi.desktop
new file mode 100644
index 000000000000..cf3af5fb0cd5
--- /dev/null
+++ b/wasabi.desktop
@@ -0,0 +1,9 @@
+[Desktop Entry]
+Name=Wasabi
+GenericName=Bitcoin Wallet
+Comment=Privacy focused Bitcoin wallet, that implements trustless coin shuffling with mathematically provable anonymity
+Exec=wasabi-wallet
+Icon=wasabi
+Terminal=false
+Type=Application
+Categories=Utility;Finance;
diff --git a/wasabi.png b/wasabi.png
new file mode 100644
index 000000000000..89929246ef54
--- /dev/null
+++ b/wasabi.png
Binary files differ