summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorKirill Goncharov2018-12-06 15:25:45 +0300
committerKirill Goncharov2018-12-06 15:25:45 +0300
commit846afe5a2792602b46687a2a56d0d5b122a9696a (patch)
tree0cbde1e5c0280e2fb6dd9980a849fd1e005cb55a
downloadaur-846afe5a2792602b46687a2a56d0d5b122a9696a.tar.gz
Version 1.0.2
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD30
2 files changed, 49 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..71e275011fa3
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = wasabi-wallet-bin
+ pkgdesc = Privacy focused, ZeroLink compliant Bitcoin wallet
+ pkgver = 1.0.2
+ pkgrel = 1
+ url = https://wasabiwallet.io/
+ arch = x86_64
+ license = MIT
+ provides = wasabi-wallet
+ conflicts = wasabi-wallet
+ options = !strip
+ options = staticlibs
+ source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.0.2/WasabiLinux-1.0.2.tar.gz
+ source = https://github.com/zkSNACKs/WalletWasabi/releases/download/v1.0.2/WasabiLinux-1.0.2.tar.gz.asc
+ validpgpkeys = 21D7CA45565DBCCEBE45115DB4B72266C47E075E
+ sha256sums = f8007eab95075e3ae6773cf5357a526770a823911b5b9b5a8bc6e104ea0880df
+ sha256sums = 74387afca4ebe33169f5d5eec41e7d58bac9bda92754344500edacf5490ec025
+
+pkgname = wasabi-wallet-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..714d8bb41d20
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,30 @@
+# Maintainer: Kirill Goncharov <kdgoncharov at gmail dot com>
+pkgname=wasabi-wallet-bin
+_pkgname=wasabi-wallet
+pkgver=1.0.2
+pkgrel=1
+pkgdesc="Privacy focused, ZeroLink compliant Bitcoin wallet"
+arch=('x86_64')
+options=(!strip staticlibs)
+url="https://wasabiwallet.io/"
+license=('MIT')
+provides=('wasabi-wallet')
+conflicts=('wasabi-wallet')
+source=(
+ "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz"
+ "https://github.com/zkSNACKs/WalletWasabi/releases/download/v${pkgver}/WasabiLinux-${pkgver}.tar.gz.asc"
+)
+sha256sums=(
+ "f8007eab95075e3ae6773cf5357a526770a823911b5b9b5a8bc6e104ea0880df"
+ "74387afca4ebe33169f5d5eec41e7d58bac9bda92754344500edacf5490ec025"
+)
+# Run gpg --keyserver pool.sks-keyservers.net --recv-keys B4B72266C47E075E
+validpgpkeys=('21D7CA45565DBCCEBE45115DB4B72266C47E075E')
+
+package() {
+ install -d -m755 "${pkgdir}/opt/"
+ cp -a "$srcdir/WasabiLinux-${pkgver}" "${pkgdir}/opt/${_pkgname}"
+ chown -R root:root "$pkgdir/opt/${_pkgname}"
+ install -d -m755 "${pkgdir}/usr/bin/"
+ ln -s "/opt/${_pkgname}/wassabee" "${pkgdir}/usr/bin/${_pkgname}"
+}