summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorPaulo Matias2021-11-03 17:36:11 -0300
committerPaulo Matias2021-11-03 17:36:11 -0300
commit3a14e04f5ffaa7b44003cbcb9bc4185f57cdcad8 (patch)
tree53858f35abbd59d4165fee1b1f6a928eba7b392a
parentcacbf62fd7c640f760beeedd89f802620c6fd93b (diff)
downloadaur-3a14e04f5ffaa7b44003cbcb9bc4185f57cdcad8.tar.gz
another try at disabling exceptions
-rw-r--r--PKGBUILD7
1 files changed, 3 insertions, 4 deletions
diff --git a/PKGBUILD b/PKGBUILD
index 085ef5a3d1d1..b194d57525aa 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,9 +6,9 @@ arch=("x86_64")
license=('Apache')
depends=(clang lld)
makedepends=(cmake ninja python git)
-source=('git+https://github.com/whitequark/wasi-sdk#branch=exception-handling'
+source=('git+https://github.com/WebAssembly/wasi-sdk.git'
'git+https://git.savannah.gnu.org/git/config.git'
- 'git+https://github.com/whitequark/llvm-project.git#branch=wasm-unwinding'
+ 'git+https://github.com/llvm/llvm-project.git'
'git+https://github.com/WebAssembly/wasi-libc.git')
md5sums=('SKIP'
'SKIP'
@@ -24,9 +24,8 @@ prepare() {
git config submodule.src/config.url "$srcdir/config"
git config submodule.src/llvm-project.url "$srcdir/llvm-project"
git config submodule.src/wasi-libc.url "$srcdir/wasi-libc"
- git submodule set-branch --branch wasm-unwinding src/llvm-project
- git submodule update --remote src/llvm-project
git submodule update
+ sed -ri 's/^DEBUG_PREFIX_MAP=/DEBUG_PREFIX_MAP=-fno-exceptions /' Makefile
}
pkgver() {