summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkpcyrd2017-12-04 15:13:31 +0100
committerkpcyrd2017-12-04 15:13:31 +0100
commit8fc1d6eaeb5be4003a0ac2d33af06f32a4deb743 (patch)
tree36ad68230795a98a274c3fcb998ff7ab0c7e75e5
downloadaur-8fc1d6eaeb5be4003a0ac2d33af06f32a4deb743.tar.gz
v0.0.0-1
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD27
2 files changed, 47 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f3d68fb92d8e
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = wasm-gc-git
+ pkgdesc = gc-sections for wasm
+ pkgver = 0.0.0
+ pkgrel = 1
+ url = https://github.com/alexcrichton/wasm-gc
+ arch = i686
+ arch = x86_64
+ arch = armv6h
+ license = MIT
+ license = APACHE
+ depends = cargo
+ depends = gcc-libs
+ provides = wasm-gc
+ conflicts = wasm-gc
+ source = git+https://github.com/alexcrichton/wasm-gc.git
+ sha256sums = SKIP
+ sha512sums = SKIP
+
+pkgname = wasm-gc-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..49d95a71554a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,27 @@
+# Maintainer: kpcyrd <git@rxv.cc>
+
+_gitname=wasm-gc
+pkgname=wasm-gc-git
+pkgver=0.0.0
+pkgrel=1
+pkgdesc="gc-sections for wasm"
+url="https://github.com/alexcrichton/wasm-gc"
+depends=('cargo' 'gcc-libs')
+provides=('wasm-gc')
+conflicts=('wasm-gc')
+arch=('i686' 'x86_64' 'armv6h')
+license=('MIT' 'APACHE')
+source=("git+https://github.com/alexcrichton/$_gitname.git")
+sha256sums=('SKIP')
+sha512sums=('SKIP')
+
+build() {
+ cd "$_gitname"
+ cargo build --release
+}
+
+package() {
+ cd "$_gitname"
+ install -Dm755 "target/release/$_gitname" "$pkgdir/usr/bin/$_gitname"
+ install -Dm644 LICENSE-MIT LICENSE-APACHE -t "${pkgdir}/usr/share/licenses/${pkgname}"
+}