summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLuis Martinez2023-01-21 18:18:52 -0600
committerLuis Martinez2023-01-21 18:18:52 -0600
commit749f9b04721857e3ab07263996f7563adbea4599 (patch)
treeac57033647482524f6c7f7214843f7ed0dc83d29
parent7be72026e7957d3c7fa4f5eca70435de00eff853 (diff)
downloadaur-749f9b04721857e3ab07263996f7563adbea4599.tar.gz
add static lib and headers
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
2 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 56108fdffd82..3029ccbe13de 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = wasm-micro-runtime
pkgdesc = Standalone WebAssembly (WASM) runtime with small footprint
pkgver = 1.1.2
- pkgrel = 1
+ pkgrel = 2
url = https://github.com/bytecodealliance/wasm-micro-runtime
changelog = RELEASE_NOTES.md
arch = x86_64
diff --git a/PKGBUILD b/PKGBUILD
index aaae65a0b358..e298feef62b2 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -3,7 +3,7 @@
pkgname=wasm-micro-runtime
pkgver=1.1.2
-pkgrel=1
+pkgrel=2
pkgdesc="Standalone WebAssembly (WASM) runtime with small footprint"
arch=('x86_64')
url="https://github.com/bytecodealliance/wasm-micro-runtime"
@@ -22,9 +22,17 @@ build() {
-DCMAKE_BUILD_TYPE=Release \
-DCMAKE_INSTALL_PREFIX=/usr \
-Wno-dev
+ cmake \
+ -B build-lib \
+ -S "$pkgname-WAMR-$pkgver" \
+ -DCMAKE_BUILD_TYPE=Release \
+ -DCMAKE_INSTALL_PREFIX=/usr \
+ -Wno-dev
cmake --build build
+ cmake --build build-lib
}
package() {
DESTDIR="${pkgdir}" cmake --install build
+ DESTDIR="${pkgdir}" cmake --install build-lib
}