summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-08-30 18:05:03 +0200
committerDario Ostuni2019-08-30 18:05:03 +0200
commit2a81d457845a53686926fb733813106358c8d58c (patch)
tree586a99a2be26f7b3c4aa14e7ff9bc5c0a4e32db3
downloadaur-2a81d457845a53686926fb733813106358c8d58c.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..8a9dbe16580f
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wasm-pack
+ pkgdesc = Simple http server in Rust
+ pkgver = 0.8.1
+ pkgrel = 1
+ url = https://github.com/rustwasm/wasm-pack
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = MIT
+ makedepends = cargo
+ source = https://github.com/rustwasm/wasm-pack/archive/v0.8.1.tar.gz
+ sha384sums = f9f937138e97890bb56d20d6e1c76739c18a0edabdd921f246926787aeb538642ec01b038d45ba6a17e31a2c9adf1355
+
+pkgname = wasm-pack
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8f3333e3d77a
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+
+pkgname=wasm-pack
+pkgver=0.8.1
+pkgrel=1
+pkgdesc="Simple http server in Rust"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/rustwasm/wasm-pack"
+license=('MIT')
+depends=()
+makedepends=('cargo')
+options=()
+source=("https://github.com/rustwasm/wasm-pack/archive/v${pkgver}.tar.gz")
+sha384sums=('f9f937138e97890bb56d20d6e1c76739c18a0edabdd921f246926787aeb538642ec01b038d45ba6a17e31a2c9adf1355')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+}