summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNoah2020-04-27 19:30:07 -0500
committerNoah2020-04-27 19:30:07 -0500
commit2bf279052cd81ad1e5968f7cae47edba1dbb3ca3 (patch)
treeeda3b2dd51450e9ecfd234542609a562a8d1abed
downloadaur-2bf279052cd81ad1e5968f7cae47edba1dbb3ca3.tar.gz
Initial commit
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..1199c80f4f11
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = wasm3-git
+ pkgdesc = A high performance WebAssembly interpreter written in C
+ pkgver = v0.4.7.r0.3b970de
+ pkgrel = 1
+ url = https://github.com/wasm3/wasm3
+ arch = x86_64
+ arch = i686
+ license = MIT
+ makedepends = git
+ makedepends = cmake
+ provides = wasm3
+ conflicts = wasm3
+ source = wasm3::git+https://github.com/wasm3/wasm3
+ md5sums = SKIP
+
+pkgname = wasm3-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..055588f04844
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: Noah (coolreader18)
+pkgname=wasm3-git
+pkgver=v0.4.7.r0.3b970de
+pkgrel=1
+pkgdesc="A high performance WebAssembly interpreter written in C"
+arch=(x86_64 i686)
+url="https://github.com/wasm3/wasm3"
+license=('MIT')
+groups=()
+depends=()
+makedepends=('git' 'cmake')
+provides=("${pkgname%-git}")
+conflicts=("${pkgname%-git}")
+replaces=()
+backup=()
+options=()
+install=
+source=('wasm3::git+https://github.com/wasm3/wasm3')
+noextract=()
+md5sums=('SKIP')
+
+pkgver() {
+ cd "$srcdir/${pkgname%-git}"
+ printf "%s" "$(git describe --long --tags | sed 's/\([^-]*-\)g/r\1/;s/-/./g')"
+}
+
+build() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p build
+ cd build
+ cmake .. -DCMAKE_INSTALL_PREFIX=/usr
+ make
+}
+
+package() {
+ cd "$srcdir/${pkgname%-git}"
+ mkdir -p "$pkgdir"/usr/bin
+ install ./build/wasm3 "$pkgdir"/usr/bin
+}