summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortee2023-07-30 23:00:31 +1200
committertee2023-07-30 23:00:31 +1200
commit10053a40a338c63e15c1c6da88d74754b29f17c1 (patch)
tree7fb793bbb209d56b350ddb59b0113ff0164dba3f
parent55c2b3721331cb87af4ec2dbebbeb295a0dff6ae (diff)
downloadaur-10053a40a338c63e15c1c6da88d74754b29f17c1.tar.gz
Update 13.3.3
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD14
2 files changed, 9 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5b4e4ecc4dae..c068be44f1c2 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wasmedge
pkgdesc = WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime for cloud native, edge, and decentralized applications. It powers serverless apps, embedded functions, microservices, smart contracts, and IoT devices.
- pkgver = 0.11.2
+ pkgver = 0.13.3
pkgrel = 1
url = https://wasmedge.org
arch = any
@@ -11,7 +11,7 @@ pkgbase = wasmedge
depends = pkgconf
depends = ninja
depends = rapidjson
- source = https://github.com/WasmEdge/WasmEdge/archive/refs/tags/0.11.2.tar.gz
- sha256sums = aa1d484707aecd66833cf75f8428372203f4f470f47c44ff174d7ef1706ffe76
+ source = https://github.com/WasmEdge/WasmEdge/archive/refs/tags/0.13.3.tar.gz
+ sha256sums = ad7a09f1a0f245473af748244f656387841e9f496b894a66feee954066bb6454
pkgname = wasmedge
diff --git a/PKGBUILD b/PKGBUILD
index 0368a406cc04..2af51fd0d102 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,24 +1,22 @@
# Maintainer: Po-An, Yang (Antonio Yang) <yanganto at gmail.com>
-set -u
+# Maintainer: tee < teeaur at duck dot com >
pkgname='wasmedge'
-pkgver=0.11.2
-pkgrel='1'
+pkgver=0.13.3
+pkgrel=1
pkgdesc='WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime for cloud native, edge, and decentralized applications. It powers serverless apps, embedded functions, microservices, smart contracts, and IoT devices.'
arch=('any')
url='https://wasmedge.org'
license=('Apache')
depends=('cmake' 'boost' 'openssl' 'pkgconf' 'ninja' 'rapidjson')
source=("https://github.com/WasmEdge/WasmEdge/archive/refs/tags/${pkgver}.tar.gz")
-sha256sums=('aa1d484707aecd66833cf75f8428372203f4f470f47c44ff174d7ef1706ffe76')
+sha256sums=('ad7a09f1a0f245473af748244f656387841e9f496b894a66feee954066bb6454')
package() {
- set -u
install -d "${pkgdir}/usr"
cd "${srcdir}/WasmEdge-${pkgver}"
- cmake -Bbuild -GNinja -DCMAKE_BUILD_TYPE=Release -DWASMEDGE_BUILD_TESTS=ON -DWASMEDGE_BUILD_AOT_RUNTIME=OFF -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr .
+ cmake -Bbuild -GNinja -DCMAKE_BUILD_TYPE=Release -DWASMEDGE_BUILD_TESTS=ON \
+ -DWASMEDGE_BUILD_AOT_RUNTIME=OFF -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr .
cmake --build build
cd "${srcdir}/WasmEdge-${pkgver}/build"
ninja install
- set +u
}
-set +u