summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAntonio Yang2021-12-08 13:46:32 +0800
committerAntonio Yang2021-12-08 13:46:32 +0800
commitb91f01c276458b007efc488b29740176666af64d (patch)
tree27a8dadca0b002882d0aa30bf42b0b64a41b08fb
downloadaur-b91f01c276458b007efc488b29740176666af64d.tar.gz
Init wasmedge 0.8.2
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD24
2 files changed, 40 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6fe6d0de4fa6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wasmedge
+ pkgdesc = WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime for cloud native, edge, and decentralized applications. It powers serverless apps, embedded functions, microservices, smart contracts, and IoT devices.
+ pkgver = 0.8.2
+ pkgrel = 1
+ url = https://wasmedge.org
+ arch = any
+ license = Apache
+ depends = cmake
+ depends = boost
+ depends = openssl
+ depends = pkgconf
+ depends = ninja
+ source = https://github.com/WasmEdge/WasmEdge/archive/refs/tags/0.8.2.tar.gz
+ sha256sums = d21fac6e213b438371d6ba12308bbc3bef5842f8a89d9965874a5785c4f970fc
+
+pkgname = wasmedge
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..259fe35a4cd6
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,24 @@
+# Maintainer: Po-An, Yang (Antonio Yang) <yanganto at gmail.com>
+set -u
+pkgname='wasmedge'
+pkgver=0.8.2
+pkgrel='1'
+pkgdesc='WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime for cloud native, edge, and decentralized applications. It powers serverless apps, embedded functions, microservices, smart contracts, and IoT devices.'
+arch=('any')
+url='https://wasmedge.org'
+license=('Apache')
+depends=('cmake' 'boost' 'openssl' 'pkgconf' 'ninja')
+source=("https://github.com/WasmEdge/WasmEdge/archive/refs/tags/${pkgver}.tar.gz")
+sha256sums=('d21fac6e213b438371d6ba12308bbc3bef5842f8a89d9965874a5785c4f970fc')
+
+package() {
+ set -u
+ install -d "${pkgdir}/usr"
+ cd "${srcdir}/WasmEdge-${pkgver}"
+ cmake -Bbuild -GNinja -DCMAKE_BUILD_TYPE=Release -DWASMEDGE_BUILD_TESTS=ON -DWASMEDGE_BUILD_AOT_RUNTIME=OFF -DCMAKE_INSTALL_PREFIX=${pkgdir}/usr .
+ cmake --build build
+ cd "${srcdir}/WasmEdge-${pkgver}/build"
+ ninja install
+ set +u
+}
+set +u