summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authortee2023-07-22 01:02:22 +1200
committertee2023-07-22 01:02:22 +1200
commitf24745aa0f046dff97cf22ae7912e150a81aed1c (patch)
treeaa333ed236dbb4e675a5d01f57360beaecb7e642
downloadaur-f24745aa0f046dff97cf22ae7912e150a81aed1c.tar.gz
Initial commit for version 0.13.2
-rw-r--r--.SRCINFO24
-rw-r--r--PKGBUILD40
2 files changed, 64 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..a3b8c66b93f6
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,24 @@
+pkgbase = wasmedge
+ pkgdesc = WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime
+ pkgver = 0.13.2
+ pkgrel = 1
+ url = https://wasmedge.org
+ arch = x86_64
+ arch = aarch64
+ license = APACHE
+ source = https://github.com/WasmEdge/WasmEdge/raw/master/LICENSE
+ sha256sums = c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4
+ source_x86_64 = https://github.com/WasmEdge/WasmEdge/releases/download/0.13.2/WasmEdge-0.13.2-manylinux2014_x86_64.tar.xz
+ source_x86_64 = https://github.com/WasmEdge/WasmEdge/releases/download/0.13.2/WasmEdge-plugin-wasi_crypto-0.13.2-manylinux2014_x86_64.tar.gz
+ sha256sums_x86_64 = 5b7c3ec27ffc63d908fe396afe39b432365937af96776ab64629c500e831ab42
+ sha256sums_x86_64 = 1449ee64da40f08b32c4072cd67abbebffea1e59c9326ec5688f0277ed6bc9ff
+ source_aarch64 = https://github.com/WasmEdge/WasmEdge/releases/download/0.13.2/WasmEdge-0.13.2-manylinux2014_aarch64.tar.xz
+ sha256sums_aarch64 = 7e71dc3a3cf454b5eaf052720f2b3fac71e0a9310b0ba76dfce2762c7036a904
+
+pkgname = wasmedge-bin
+ provides = wasmedge
+ conflicts = wasmedge
+
+pkgname = wasmedge-plugin-wasi-crypto
+ pkgdesc = WasmEdge wasi crypto plugin
+ depends = wasmedge
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9d9830509ce1
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+# Maintainer: tee < teeaur at duck dot com >
+pkgbase=wasmedge
+_pkgname=WasmEdge
+pkgname=(
+ wasmedge-bin
+ wasmedge-plugin-wasi-crypto
+)
+pkgver=0.13.2
+pkgrel=1
+pkgdesc="WasmEdge is a lightweight, high-performance, and extensible WebAssembly runtime"
+arch=(x86_64 aarch64)
+url="https://wasmedge.org"
+_url="https://github.com/WasmEdge/WasmEdge"
+license=(APACHE)
+source=("$_url/raw/master/LICENSE")
+source_x86_64=("$_url/releases/download/$pkgver/$_pkgname-$pkgver-manylinux2014_x86_64.tar.xz"
+"$_url/releases/download/$pkgver/$_pkgname-plugin-wasi_crypto-$pkgver-manylinux2014_x86_64.tar.gz")
+source_aarch64=("$_url/releases/download/$pkgver/$_pkgname-$pkgver-manylinux2014_aarch64.tar.xz")
+sha256sums=('c71d239df91726fc519c6eb72d318ec65820627232b2f796219e87dcf35d0ab4')
+sha256sums_x86_64=('5b7c3ec27ffc63d908fe396afe39b432365937af96776ab64629c500e831ab42'
+ '1449ee64da40f08b32c4072cd67abbebffea1e59c9326ec5688f0277ed6bc9ff')
+sha256sums_aarch64=('7e71dc3a3cf454b5eaf052720f2b3fac71e0a9310b0ba76dfce2762c7036a904')
+
+package_wasmedge-bin() {
+ provides=(wasmedge)
+ conflicts=(wasmedge)
+ install -Dm644 LICENSE -t $pkgdir/usr/share/licenses/${_pkgname,,}/
+ cd $_pkgname-$pkgver-Linux
+ install -Dm755 bin/$pkgbase -t $pkgdir/usr/bin/
+ install -Dm755 lib64/libwasmedge.so.0.0.3 -t $pkgdir/usr/lib/
+ cp -d lib64/libwasmedge.so -t $pkgdir/usr/lib/
+ cp -d lib64/libwasmedge.so.0 -t $pkgdir/usr/lib/
+ install -D include/$pkgbase/* -t $pkgdir/usr/include/
+}
+
+package_wasmedge-plugin-wasi-crypto() {
+ pkgdesc='WasmEdge wasi crypto plugin'
+ depends=(wasmedge)
+ install -Dm755 libwasmedgePluginWasiCrypto.so -t $pkgdir/usr/lib/
+}