summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulius Michaelis2021-02-16 21:11:04 +0900
committerJulius Michaelis2021-02-16 21:11:04 +0900
commit6847b12dc4a0fc9ef1024c6ca4c12c096b82d0e1 (patch)
treee1f6c3e263cbad59677e6f67df106c69235846f3
parent7aa91aa0e1bb4ef716b0864a5e8481307531fb5b (diff)
downloadaur-6847b12dc4a0fc9ef1024c6ca4c12c096b82d0e1.tar.gz
Make sure feature flags are set when building binary
-rw-r--r--PKGBUILD6
1 files changed, 4 insertions, 2 deletions
diff --git a/PKGBUILD b/PKGBUILD
index f0c2bdb29de4..cb2cf0b3470f 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,14 +15,16 @@ sha512sums=('f8058cbd5a8a807cd84b4a839c87ff76dae5475c655e804b27262cd5cb22ddb6c43
build() {
cd "$pkgname-$pkgver"
-
- cargo build --all --release --locked --features "cranelift llvm singlepass"
+ cargo build --release --locked --manifest-path lib/c-api/Cargo.toml --no-default-features --features deprecated,wat,jit,native,object-file,cranelift,wasi
+ cargo build --release --locked --manifest-path lib/cli/Cargo.toml --features "cranelift llvm singlepass" --bin wasmer
}
check() {
cd "$pkgname-$pkgver"
cargo test --release --locked --manifest-path lib/cli/Cargo.toml --features "cranelift llvm singlepass" --bin wasmer
+ # Check if we can run a basic binary
+ target/release/wasmer run tests/wasi-wast/wasi/snapshot1/hello.wasm &>/dev/null
}
package() {