summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJulius Michaelis2021-02-16 21:11:10 +0900
committerJulius Michaelis2021-02-16 21:11:10 +0900
commitadf366feff0bcf6bc0095011971414121400ce81 (patch)
tree8f7822bbd0434ef9bafe1339e65f050c0c7aceba
parent6847b12dc4a0fc9ef1024c6ca4c12c096b82d0e1 (diff)
downloadaur-adf366feff0bcf6bc0095011971414121400ce81.tar.gz
Install static library so wasmer-create-exe can work
-rw-r--r--PKGBUILD2
1 files changed, 2 insertions, 0 deletions
diff --git a/PKGBUILD b/PKGBUILD
index cb2cf0b3470f..2ccaab33d557 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -12,6 +12,7 @@ makedepends=('rust' 'cmake' 'python' 'libxkbcommon')
checkdepends=('llvm')
source=("$pkgname-$pkgver.tar.gz::https://github.com/wasmerio/wasmer/archive/${pkgver}.tar.gz")
sha512sums=('f8058cbd5a8a807cd84b4a839c87ff76dae5475c655e804b27262cd5cb22ddb6c43da3a01b6cdbed29502afc38aa9ee589022f67fab27b189453f2500478c4a9')
+options=('staticlibs')
build() {
cd "$pkgname-$pkgver"
@@ -36,6 +37,7 @@ package() {
done
install -Dm755 target/release/libwasmer_c_api.so "$pkgdir/usr/lib/libwasmer.so.$pkgver"
+ install -Dm755 target/release/libwasmer_c_api.a "$pkgdir/usr/lib/libwasmer.a"
local _shortver="${pkgver%.*}"
local _majorver="${_shortver%.*}"
ln -s "libwasmer.so.$pkgver" "$pkgdir/usr/lib/libwasmer.so.$_shortver"