summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2020-03-12 15:12:39 +0700
committerkhai96_2020-03-12 15:12:39 +0700
commit1a9fca835958ea3c4327b4b96c71dfafd06230c7 (patch)
treec9464ee8b1932ef075aa4a262bbd3be6dce927ac
parent6412061eff42437cd0664cefe515ec9ecfccee6c (diff)
downloadaur-1a9fca835958ea3c4327b4b96c71dfafd06230c7.tar.gz
Remove wapm.sh
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD7
-rwxr-xr-xwapm.sh4
3 files changed, 2 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 53c5d3465e3e..52ddc6183db4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -12,12 +12,10 @@ pkgbase = wasmer-bin
conflicts = wapm
source = wasmer-linux-amd64-0.16.2.tar.gz::https://github.com/wasmerio/wasmer/releases/download/0.16.2/wasmer-linux-amd64.tar.gz
source = https://raw.githubusercontent.com/wasmerio/wasmer/0.16.2/LICENSE
- source = wapm.sh
source = logo.sh
sha512sums = SKIP
sha512sums = SKIP
sha512sums = SKIP
- sha512sums = SKIP
pkgname = wasmer-bin
diff --git a/PKGBUILD b/PKGBUILD
index 1f1e631b7d7e..29f1a59e6910 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -13,10 +13,9 @@ provides=(wasmer wapm)
source=(
"wasmer-linux-amd64-${pkgver}.tar.gz"::"https://github.com/wasmerio/wasmer/releases/download/${pkgver}/wasmer-linux-amd64.tar.gz"
"https://raw.githubusercontent.com/wasmerio/wasmer/${pkgver}/LICENSE"
- wapm.sh
logo.sh
)
-sha512sums=(SKIP SKIP SKIP SKIP)
+sha512sums=(SKIP SKIP SKIP)
build() {
cd "$srcdir"
@@ -34,9 +33,7 @@ package() {
# executable commands
install -Dm755 bin/wasmer "$pkgdir"/usr/bin/wasmer
- install -Dm755 wapm.sh "$pkgdir"/usr/bin/wapm.sh
- install -Dm755 bin/wapm "$pkgdir"/usr/bin/wapm.bin
- ln -s wapm.sh "$pkgdir"/usr/bin/wapm
+ install -Dm755 bin/wapm "$pkgdir"/usr/bin/wapm
# wapm completions
install -Dm644 wapm-bash-completions "$pkgdir"/usr/share/bash-completion/completions/wapm
diff --git a/wapm.sh b/wapm.sh
deleted file mode 100755
index 11610f528378..000000000000
--- a/wapm.sh
+++ /dev/null
@@ -1,4 +0,0 @@
-#! /usr/bin/bash
-export WASMER_DIR="${WASMER_DIR:-$HOME/.wasmer}"
-export WASMER_CACHE_DIR="${WASMER_CACHE_DIR:-$WASMER_DIR/cache}"
-exec wapm.bin "$@"