summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2021-01-06 07:25:28 +0700
committerkhai96_2021-01-06 07:25:28 +0700
commit5604d0e39ef874096079db3742e7f65f0b7228f3 (patch)
tree61c760dc0df904f0271f935aa9844c3c9e3367f2
parent3f7d5ef34eaf8befd646684adfbf8955e0af3497 (diff)
downloadaur-5604d0e39ef874096079db3742e7f65f0b7228f3.tar.gz
Change code style
-rw-r--r--PKGBUILD40
1 files changed, 22 insertions, 18 deletions
diff --git a/PKGBUILD b/PKGBUILD
index c1a43719ad6f..7f9ff7f73d5a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,28 +1,32 @@
# Maintainer: Hoàng Văn Khải <hvksmr1996@gmail.com>
-pkgname=wasmer-bin
-pkgver=0.17.1
-pkgrel=0
+pkgname='wasmer-bin'
+pkgver='0.17.1'
+pkgrel='0'
pkgdesc='Universal WebAssembly runtime'
-arch=(x86_64)
-license=(MIT)
+arch=('x86_64')
+license=('MIT')
url='https://wasmer.io/'
-depends=(bash)
-conflicts=(wasmer wapm)
-provides=(wasmer wapm)
+depends=('bash')
+conflicts=('wasmer' 'wapm')
+provides=('wasmer' 'wapm')
source=(
"wasmer-linux-amd64-${pkgver}.tar.gz"::"https://github.com/wasmerio/wasmer/releases/download/${pkgver}/wasmer-linux-amd64.tar.gz"
"https://raw.githubusercontent.com/wasmerio/wasmer/${pkgver}/LICENSE"
- logo.sh
+ 'logo.sh'
+)
+sha512sums=(
+ 'SKIP'
+ 'SKIP'
+ 'SKIP'
)
-sha512sums=(SKIP SKIP SKIP)
build() {
cd "$srcdir"
# wapm completions
- ./bin/wapm completions bash > wapm-bash-completions
- ./bin/wapm completions zsh > wapm-zsh-completions
+ ./bin/wapm completions bash >wapm-bash-completions
+ ./bin/wapm completions zsh >wapm-zsh-completions
}
package() {
@@ -32,14 +36,14 @@ package() {
source logo.sh
# executable commands
- install -Dm755 bin/wasmer "$pkgdir"/usr/bin/wasmer
- install -Dm755 bin/wapm "$pkgdir"/usr/bin/wapm
- ln -s wapm "$pkgdir"/usr/bin/wax
+ install -Dm755 bin/wasmer "$pkgdir/usr/bin/wasmer"
+ install -Dm755 bin/wapm "$pkgdir/usr/bin/wapm"
+ ln -s wapm "$pkgdir/usr/bin/wax"
# wapm completions
- install -Dm644 wapm-bash-completions "$pkgdir"/usr/share/bash-completion/completions/wapm
- install -Dm644 wapm-zsh-completions "$pkgdir"/usr/share/zsh/site-functions/_wapm
+ install -Dm644 wapm-bash-completions "$pkgdir/usr/share/bash-completion/completions/wapm"
+ install -Dm644 wapm-zsh-completions "$pkgdir/usr/share/zsh/site-functions/_wapm"
# license
- install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
+ install -Dm644 LICENSE "$pkgdir/usr/share/licenses/$pkgname/LICENSE"
}