summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorkhai96_2019-04-24 00:38:17 +0700
committerkhai96_2019-04-24 00:38:17 +0700
commit694b3620581068845b3f0175fb03d30ee5e82aef (patch)
treec2c69956fd44c4d44dc036a9cfcb58dafda2434c
parentcc0fbf121dfd8ed897b6b10f5e76a87ee49517b0 (diff)
downloadaur-694b3620581068845b3f0175fb03d30ee5e82aef.tar.gz
provides wapm binary
-rw-r--r--.SRCINFO4
-rw-r--r--PKGBUILD5
2 files changed, 6 insertions, 3 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 5194e01fbe9d..6a2ee5607954 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -6,9 +6,11 @@ pkgbase = wasmer-bin
arch = x86_64
license = MIT
provides = wasmer
+ provides = wapm
conflicts = wasmer
+ conflicts = wapm
source = https://github.com/wasmerio/wasmer/releases/download/0.4.0/wasmer-linux-amd64.tar.gz
- source = https://raw.githubusercontent.com/wasmerio/wasmer/0.3.0/LICENSE
+ source = https://raw.githubusercontent.com/wasmerio/wasmer/0.4.0/LICENSE
source = logo.sh
sha512sums = SKIP
sha512sums = SKIP
diff --git a/PKGBUILD b/PKGBUILD
index cc453a5433da..78a7b43be39a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -8,8 +8,8 @@ arch=(x86_64)
license=(MIT)
url='https://wasmer.io/'
depends=()
-conflicts=(wasmer)
-provides=(wasmer)
+conflicts=(wasmer wapm)
+provides=(wasmer wapm)
source=(
"https://github.com/wasmerio/wasmer/releases/download/${pkgver}/wasmer-linux-amd64.tar.gz"
"https://raw.githubusercontent.com/wasmerio/wasmer/${pkgver}/LICENSE"
@@ -21,5 +21,6 @@ package() {
cd "$srcdir"
source logo.sh
install -Dm755 bin/wasmer "$pkgdir"/usr/bin/wasmer
+ install -Dm755 bin/wapm "$pkgdir"/usr/bin/wapm
install -Dm644 LICENSE "$pkgdir"/usr/share/licenses/"$pkgname"/LICENSE
}