summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorDario Ostuni2019-08-30 18:19:43 +0200
committerDario Ostuni2019-08-30 18:19:43 +0200
commit3e1e079400d50dc498d90b606a0a92b9390a0112 (patch)
tree5ea539e17e0242728bb9f7e760e51e26b2518bca
downloadaur-3e1e079400d50dc498d90b606a0a92b9390a0112.tar.gz
Initial commit
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD26
2 files changed, 42 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..325efcbba710
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = wasmtime
+ pkgdesc = Standalone JIT-style runtime for WebAssembly, using Cranelift
+ pkgver = 0.3.0
+ pkgrel = 1
+ url = https://github.com/CraneStation/wasmtime
+ arch = i686
+ arch = x86_64
+ arch = armv7h
+ arch = aarch64
+ license = APACHE2
+ makedepends = cargo
+ source = https://github.com/CraneStation/wasmtime/archive/v0.3.0.tar.gz
+ sha384sums = c043bf58f24a174d832b14b4aa1a6de17cd608648753da65c64f33254e79df913ce0e709abcd9645e71ebed4c2134360
+
+pkgname = wasmtime
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..211ad2c50317
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,26 @@
+# Maintainer: Dario Ostuni <dario.ostuni@gmail.com>
+
+pkgname=wasmtime
+pkgver=0.3.0
+pkgrel=1
+pkgdesc="Standalone JIT-style runtime for WebAssembly, using Cranelift"
+arch=('i686' 'x86_64' 'armv7h' 'aarch64')
+url="https://github.com/CraneStation/wasmtime"
+license=('APACHE2')
+depends=()
+makedepends=('cargo')
+options=()
+source=("https://github.com/CraneStation/wasmtime/archive/v${pkgver}.tar.gz")
+sha384sums=('c043bf58f24a174d832b14b4aa1a6de17cd608648753da65c64f33254e79df913ce0e709abcd9645e71ebed4c2134360')
+
+build() {
+ cd "$srcdir/$pkgname-$pkgver"
+ cargo build --release
+}
+
+package() {
+ cd "$srcdir/$pkgname-$pkgver"
+ install -Dm755 "target/release/$pkgname" "$pkgdir/usr/bin/$pkgname"
+ install -Dm755 "target/release/wasm2obj" "$pkgdir/usr/bin/wasm2obj"
+ install -Dm755 "target/release/wast" "$pkgdir/usr/bin/wast"
+}