summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorChocobo12023-04-06 04:56:41 +0800
committerChocobo12023-04-06 04:56:41 +0800
commit17828f8421361eeb8307187873eaa2de45e4dba6 (patch)
treed99a0ae1506de8041373e5d4f7890207edc6c76a
parent89aeaccb39d25ec876fce6809dfc5f67e195ef81 (diff)
downloadaur-17828f8421361eeb8307187873eaa2de45e4dba6.tar.gz
upgpkg: wasmtime-git 7.0.0.r157.g7eb891409-1
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD18
2 files changed, 13 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index aa7db09e17e5..a572b8f4f998 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = wasmtime-git
pkgdesc = Standalone JIT-style runtime for WebAssembly
- pkgver = 0.46.1.r6070.g1c7fa7f78
+ pkgver = 7.0.0.r157.g7eb891409
pkgrel = 1
url = https://wasmtime.dev/
arch = i686
@@ -9,10 +9,9 @@ pkgbase = wasmtime-git
makedepends = git
makedepends = rust
depends = gcc-libs
- provides = wasmtime
+ provides = wasmtime=7.0.0.r157.g7eb891409
conflicts = wasmtime
source = git+https://github.com/bytecodealliance/wasmtime.git
sha256sums = SKIP
pkgname = wasmtime-git
-
diff --git a/PKGBUILD b/PKGBUILD
index 360ac9c6ad77..0fc11c22d23d 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Chocobo1 <chocobo1 AT archlinux DOT net>
pkgname=wasmtime-git
-pkgver=0.46.1.r6070.g1c7fa7f78
+pkgver=7.0.0.r157.g7eb891409
pkgrel=1
pkgdesc="Standalone JIT-style runtime for WebAssembly"
arch=('i686' 'x86_64')
@@ -9,7 +9,7 @@ url="https://wasmtime.dev/"
license=('apache')
depends=('gcc-libs')
makedepends=('git' 'rust')
-provides=('wasmtime')
+provides=("wasmtime=$pkgver")
conflicts=('wasmtime')
source=("git+https://github.com/bytecodealliance/wasmtime.git")
sha256sums=('SKIP')
@@ -18,7 +18,12 @@ sha256sums=('SKIP')
prepare() {
cd "wasmtime"
- git submodule update --init
+ git submodule update --init --recursive
+
+ if [ ! -f "Cargo.lock" ]; then
+ cargo update
+ fi
+ cargo fetch
}
pkgver() {
@@ -34,18 +39,17 @@ check() {
cd "wasmtime"
#cargo test \
- # --locked \
- # --release
+ # --frozen
}
package() {
cd "wasmtime"
cargo install \
- --no-track \
--locked \
+ --no-track \
--root "$pkgdir/usr" \
- --path "$srcdir/wasmtime"
+ --path .
install -Dm644 "README.md" -t "$pkgdir/usr/share/doc/wasmtime"
}