summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlex Szczuczko2015-06-10 19:14:42 +0100
committerAlex Szczuczko2015-06-10 19:14:42 +0100
commitc8e5bda4db443261aa9e0ea4eea7894efec79a5c (patch)
treeb9587d1ba9894d7851744a05c92a4d3e737c2250
downloadaur-c8e5bda4db443261aa9e0ea4eea7894efec79a5c.tar.gz
Initial import
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore7
-rw-r--r--PKGBUILD69
-rw-r--r--wasteland2.desktop12
4 files changed, 115 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..c676977348f8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = wasteland2
+ pkgdesc = The sequel to an adventure in post-nuclear America
+ pkgver = 1.9.0.13
+ pkgrel = 1
+ url = https://wasteland.inxile-entertainment.com/store
+ arch = i686
+ arch = x86_64
+ license = custom:commercial
+ depends = glibc
+ depends = glu
+ depends = libx11
+ depends = libxau
+ depends = libxcb
+ depends = libxcursor
+ depends = libxdmcp
+ depends = libxext
+ depends = libxfixes
+ depends = libxrandr
+ depends = libxrender
+ depends = libgl
+ source = wasteland2.desktop
+ source = gog_wasteland_2_1.9.0.13.tar.gz::file://gog_wasteland_2_1.9.0.13.tar.gz
+ sha256sums = 1400b3e11c34cbfc57e3b5cba9501a3319ddb57f066d9d09bb7799a59fb0efc0
+ sha256sums = 0f6bf4f806de3233a11ec1049f96d779f8d013dc38f296d101466701fa931728
+
+pkgname = wasteland2
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..b217312934a0
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,7 @@
+*.swp
+*.tar.gz
+*.tar.xz
+*.tar
+/extract
+/pkg
+/src
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..a38f8c34ca44
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,69 @@
+# Maintainer: Alex Szczuczko <alex@szc.ca>
+
+pkgname=wasteland2 #-gog ???
+pkgver=1.9.0.13
+pkgrel=1
+pkgdesc="The sequel to an adventure in post-nuclear America"
+arch=("i686" "x86_64")
+url="https://wasteland.inxile-entertainment.com/store"
+license=("custom:commercial")
+depends=()
+source=("${pkgname}.desktop"
+ "gog_wasteland_2_${pkgver}.tar.gz::file://gog_wasteland_2_${pkgver}.tar.gz")
+sha256sums=("1400b3e11c34cbfc57e3b5cba9501a3319ddb57f066d9d09bb7799a59fb0efc0"
+ "0f6bf4f806de3233a11ec1049f96d779f8d013dc38f296d101466701fa931728")
+
+# Modify depends for the arch type
+if [ "$CARCH" = "x86_64" ]
+then
+ depends+=('lib32-gcc-libs' 'lib32-glibc' 'lib32-glu' 'lib32-libx11' 'lib32-libxau' 'lib32-libxcb' 'lib32-libxcursor' 'lib32-libxdmcp' 'lib32-libxext' 'lib32-libxfixes' 'lib32-libxrandr' 'lib32-libxrender' 'lib32-libgl')
+else
+ depends+=('glibc' 'glu' 'libx11' 'libxau' 'libxcb' 'libxcursor' 'libxdmcp' 'libxext' 'libxfixes' 'libxrandr' 'libxrender' 'libgl')
+fi
+
+# Disable compression of the package
+PKGEXT='.pkg.tar'
+
+package() {
+ # Binaries
+ install -Dm755 "$srcdir/Wasteland 2/game/WL2" "$pkgdir/opt/$pkgname/game/WL2"
+
+ # Data
+ # Hardlink files to save the disk space and time spent copying them (they are very large)
+ cp -Ral -t "$pkgdir/opt/$pkgname/game/" "$srcdir/Wasteland 2/game/WL2_Data"
+ find "$pkgdir/opt/$pkgname/game/WL2_Data" -type d -print0 | xargs -0 chmod 755
+ find "$pkgdir/opt/$pkgname/game/WL2_Data" -type f -print0 | xargs -0 chmod 644
+
+ # Docs
+ install -m755 -d "$pkgdir/opt/$pkgname/docs/"
+ find "$srcdir/Wasteland 2/docs/" -maxdepth 1 -type f -print0 | \
+ xargs -0 install -m644 -t "$pkgdir/opt/$pkgname/docs/"
+
+ # Icon
+ install -m755 -d "$pkgdir/opt/$pkgname/"
+ install -m644 -t "$pkgdir/opt/$pkgname/" "$srcdir/Wasteland 2/support/gog-wasteland-2.png"
+
+ #
+ # System integration
+ #
+
+ # /bin
+ install -m755 -d "$pkgdir/usr/bin/"
+ ln -s "/opt/$pkgname/game/WL2" "$pkgdir/usr/bin/$pkgname"
+
+ # License
+ install -m755 -d "$pkgdir/usr/share/licenses/$pkgname/"
+ ln -s "/opt/$pkgname/docs/End User License Agreement.txt" "$pkgdir/usr/share/licenses/$pkgname/EULA"
+
+ # Icon
+ install -m755 -d "$pkgdir/usr/share/pixmaps/"
+ ln -s "/opt/$pkgname/gog-wasteland-2.png" "$pkgdir/usr/share/pixmaps/${pkgname}.png"
+
+ # .desktop File
+ install -m755 -d "$pkgdir/usr/share/applications/"
+ install -m644 -t "$pkgdir/usr/share/applications/" "$srcdir/${pkgname}.desktop"
+
+ # Doc
+ install -m755 -d "$pkgdir/usr/share/doc/"
+ ln -s "/opt/$pkgname/docs" "$pkgdir/usr/share/doc/$pkgname"
+}
diff --git a/wasteland2.desktop b/wasteland2.desktop
new file mode 100644
index 000000000000..22805e48d475
--- /dev/null
+++ b/wasteland2.desktop
@@ -0,0 +1,12 @@
+[Desktop Entry]
+Version=1.0
+Type=Application
+Icon=/usr/share/pixmaps/wasteland2.png
+Exec=/usr/bin/wasteland2
+Terminal=false
+StartupNotify=false
+
+Name=Wasteland 2
+Comment=The sequel to an adventure in post-nuclear America
+
+Categories=Game;