summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authoraksr2015-10-24 10:29:29 +0200
committeraksr2015-10-24 10:29:29 +0200
commit6f6d781e9ba86207611279c6d5eb6de710be4e2d (patch)
tree21b81aa7a4e0e19f38581dcba605fc9241140683
downloadaur-6f6d781e9ba86207611279c6d5eb6de710be4e2d.tar.gz
Start.
-rw-r--r--.SRCINFO14
-rw-r--r--PKGBUILD43
2 files changed, 57 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..eba70d61d141
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,14 @@
+pkgbase = watch-git
+ pkgdesc = Watches for changes in a directory tree and reruns a command in an acme win or just on the terminal.
+ pkgver = r48.0c9b18a
+ pkgrel = 1
+ url = https://github.com/eaburns/Watch
+ arch = i686
+ arch = x86_64
+ license = unknown
+ makedepends = git
+ makedepends = go
+ conflicts = watch
+
+pkgname = watch-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..f657dd014ee0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,43 @@
+# Maintainer: aksr <aksr at t-com dot me>
+pkgname=watch-git
+pkgver=r48.0c9b18a
+pkgrel=1
+epoch=
+pkgdesc="Watches for changes in a directory tree and reruns a command in an acme win or just on the terminal."
+arch=('i686' 'x86_64')
+url="https://github.com/eaburns/Watch"
+license=('unknown')
+groups=()
+depends=('')
+makedepends=('git' 'go')
+optdepends=()
+checkdepends=()
+provides=()
+conflicts=('watch')
+replaces=()
+backup=()
+options=()
+changelog=
+install=
+noextract=()
+_gourl=github.com/eaburns/Watch
+
+pkgver() {
+ cd "$srcdir/src/${_gourl}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ GOPATH="$srcdir" go get -fix -v -x ${_gourl}
+}
+
+check() {
+ GOPATH="$srcdir" go test -v -x ${_gourl}
+}
+
+package() {
+ cd "$srcdir"
+ install -Dm755 bin/Watch "$pkgdir/usr/bin/Watch"
+ install -Dm644 src/${_gourl}/README.md $pkgdir/usr/share/doc/$pkgname/README
+}
+