summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Bryan2017-09-23 04:54:53 -0500
committerJesse Bryan2017-09-23 04:54:53 -0500
commit1e2573d2d6c9f38fc29b500a840b436e3e5aebc2 (patch)
treeb411850408fa7e838e67c5f4f553fadfc8030360
downloadaur-1e2573d2d6c9f38fc29b500a840b436e3e5aebc2.tar.gz
release: 1.2.8
-rw-r--r--.SRCINFO16
-rw-r--r--PKGBUILD18
2 files changed, 34 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..48ce791ac1dd
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,16 @@
+pkgbase = watch-with-mpv
+ pkgdesc = The native host for the Watch with MPV Chrome extension.
+ pkgver = 1.2.8
+ pkgrel = 1
+ url = https://github.com/winneon/watch-with-mpv
+ arch = any
+ license = MIT
+ depends = mpv>=1:0.27.0
+ depends = youtube-dl>=2017.08.06
+ conflicts = watch-with-mpv-git
+ options = !strip
+ source = https://github.com/winneon/watch-with-mpv/releases/download/1.2.8/native-linux.zip
+ sha256sums = 27132545e548b447f21f1ec0a5bdfd959a8b0584770545492d8eb13211343216
+
+pkgname = watch-with-mpv
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..223f072a67cd
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,18 @@
+# Maintainer: Jesse Bryan <jesse@winneon.moe>
+pkgname=watch-with-mpv
+pkgver=1.2.8
+pkgrel=1
+pkgdesc="The native host for the Watch with MPV Chrome extension."
+arch=("any")
+url="https://github.com/winneon/${pkgname}"
+license=("MIT")
+conflicts=("${pkgname}-git")
+depends=("mpv>=1:0.27.0" "youtube-dl>=2017.08.06")
+options=("!strip") # Required to keep the packaged node binary intact.
+source=("https://github.com/winneon/watch-with-mpv/releases/download/${pkgver}/native-linux.zip")
+sha256sums=("27132545e548b447f21f1ec0a5bdfd959a8b0584770545492d8eb13211343216")
+
+package() {
+ cd "${srcdir}"
+ make DESTDIR="${pkgdir}" install
+}