summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJesse Bryan2017-09-23 04:42:26 -0500
committerJesse Bryan2017-09-23 04:42:26 -0500
commit74e3fb380e3f6af04a521a663337d0c1dd2b5e0c (patch)
treeb72c47080d87ca0c5be1a1b8ad398e03baafabaa
downloadaur-74e3fb380e3f6af04a521a663337d0c1dd2b5e0c.tar.gz
release: initial git release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD32
2 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..fda0ad5215ee
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = watch-with-mpv-git
+ pkgdesc = The native host for the Watch with MPV Chrome extension.
+ pkgver = 20170923.598067b
+ pkgrel = 1
+ url = https://github.com/winneon/watch-with-mpv-git
+ arch = any
+ license = GPL2
+ makedepends = git
+ makedepends = nodejs
+ makedepends = npm
+ depends = mpv>=1:0.27.0
+ depends = youtube-dl>=2017.08.06
+ provides = watch-with-mpv
+ conflicts = watch-with-mpv
+ options = !strip
+ source = watch-with-mpv-git::git+https://github.com/winneon/watch-with-mpv.git
+ sha256sums = SKIP
+
+pkgname = watch-with-mpv-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..32702b38bee3
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Jesse Bryan <jesse@winneon.moe>
+pkgname=watch-with-mpv-git
+_pkgname=watch-with-mpv
+pkgver=20170923.598067b
+pkgrel=1
+pkgdesc="The native host for the Watch with MPV Chrome extension."
+arch=("any")
+url="https://github.com/winneon/${pkgname}"
+license=("GPL2")
+provides=("${_pkgname}")
+conflicts=("${_pkgname}")
+depends=("mpv>=1:0.27.0" "youtube-dl>=2017.08.06")
+makedepends=("git" "nodejs" "npm")
+options=("!strip") # Required to keep the packaged node binary intact.
+source=("${pkgname}::git+https://github.com/winneon/watch-with-mpv.git")
+sha256sums=("SKIP")
+
+pkgver() {
+ cd "${pkgname}"
+ git log -1 --format="%cd.%h" --date=short | tr -d -
+}
+
+build() {
+ cd "${pkgname}/native"
+ npm install --cache "${srcdir}/npm-cache"
+ npm run build
+}
+
+package() {
+ cd "${pkgname}/native/build/linux"
+ make DESTDIR="${pkgdir}" install
+}