summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmeric2018-05-23 10:41:44 +0200
committerEmeric2018-05-23 10:41:44 +0200
commit3d247730d5d81d2e4a05ce7c42cdd78332737669 (patch)
tree7af225d8b2f3a09cb648d343a55a0af8b0d3f49e
parent42e3aca1a246e5be1667114209530062d61113e8 (diff)
downloadaur-3d247730d5d81d2e4a05ce7c42cdd78332737669.tar.gz
Update WatchFlower to v0.1.1
-rw-r--r--.SRCINFO6
-rw-r--r--PKGBUILD10
2 files changed, 5 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index bc3db1d85ae7..4a17204f425d 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = watchflower
pkgdesc = WatchFlower helps you read and plot datas from your Xiaomi 'Flower Care' devices!
- pkgver = 0.1
+ pkgver = 0.1.1
pkgrel = 1
url = https://github.com/emericg/WatchFlower
arch = i686
@@ -12,8 +12,8 @@ pkgbase = watchflower
depends = qt5-charts
depends = qt5-svg
depends = sqlite
- source = https://github.com/emericg/WatchFlower/archive/v0.1.zip
- sha256sums = 3330da0fa3c9eaeb028990c654a8e4b4fcd80979c7d1b637c11f479bdc2261fe
+ source = https://github.com/emericg/WatchFlower/archive/v0.1.1.zip
+ sha256sums = 93191cb21234b9b94cfb3722ec9db217a3ff898afa14854189a57d7972e4aac5
pkgname = watchflower
diff --git a/PKGBUILD b/PKGBUILD
index aacb700087b9..8a1b5f3d7ddb 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,7 +1,7 @@
# Maintainer: Emeric Grange <emeric.grange@gmail.com>
pkgname=watchflower
-pkgver=0.1
+pkgver=0.1.1
pkgrel=1
pkgdesc="WatchFlower helps you read and plot datas from your Xiaomi 'Flower Care' devices!"
arch=("i686" "x86_64")
@@ -10,23 +10,17 @@ license=("GPL3")
depends=("qt5-base" "qt5-connectivity" "qt5-charts" "qt5-svg" "sqlite")
makedepends=("qt5-tools")
source=("https://github.com/emericg/WatchFlower/archive/v${pkgver}.zip")
-sha256sums=('3330da0fa3c9eaeb028990c654a8e4b4fcd80979c7d1b637c11f479bdc2261fe')
+sha256sums=('93191cb21234b9b94cfb3722ec9db217a3ff898afa14854189a57d7972e4aac5')
build() {
mkdir -p "WatchFlower-${pkgver}"
cd "WatchFlower-${pkgver}"
-
- # 0.1 hacks
- mkdir -p bin/
- touch bin/watchflower
- chmod a-x assets/app/watchflower.desktop
qmake -config release PREFIX=${pkgdir}/usr/
make
}
package() {
cd "WatchFlower-${pkgver}"
- chmod a+x bin/watchflower # 0.1 hacks
make install
}