summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorEmeric2018-05-22 14:54:07 +0200
committerEmeric2018-05-22 14:54:07 +0200
commit42e3aca1a246e5be1667114209530062d61113e8 (patch)
tree717b64c6b63c017538ba3fb9e36556c03856ac60
downloadaur-42e3aca1a246e5be1667114209530062d61113e8.tar.gz
First version uploaded
-rw-r--r--.SRCINFO19
-rw-r--r--.gitignore1
-rw-r--r--PKGBUILD32
3 files changed, 52 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bc3db1d85ae7
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = watchflower
+ pkgdesc = WatchFlower helps you read and plot datas from your Xiaomi 'Flower Care' devices!
+ pkgver = 0.1
+ pkgrel = 1
+ url = https://github.com/emericg/WatchFlower
+ arch = i686
+ arch = x86_64
+ license = GPL3
+ makedepends = qt5-tools
+ depends = qt5-base
+ depends = qt5-connectivity
+ depends = qt5-charts
+ depends = qt5-svg
+ depends = sqlite
+ source = https://github.com/emericg/WatchFlower/archive/v0.1.zip
+ sha256sums = 3330da0fa3c9eaeb028990c654a8e4b4fcd80979c7d1b637c11f479bdc2261fe
+
+pkgname = watchflower
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..72e8ffc0db8a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1 @@
+*
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..aacb700087b9
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,32 @@
+# Maintainer: Emeric Grange <emeric.grange@gmail.com>
+
+pkgname=watchflower
+pkgver=0.1
+pkgrel=1
+pkgdesc="WatchFlower helps you read and plot datas from your Xiaomi 'Flower Care' devices!"
+arch=("i686" "x86_64")
+url="https://github.com/emericg/WatchFlower"
+license=("GPL3")
+depends=("qt5-base" "qt5-connectivity" "qt5-charts" "qt5-svg" "sqlite")
+makedepends=("qt5-tools")
+source=("https://github.com/emericg/WatchFlower/archive/v${pkgver}.zip")
+sha256sums=('3330da0fa3c9eaeb028990c654a8e4b4fcd80979c7d1b637c11f479bdc2261fe')
+
+build() {
+ mkdir -p "WatchFlower-${pkgver}"
+ cd "WatchFlower-${pkgver}"
+
+ # 0.1 hacks
+ mkdir -p bin/
+ touch bin/watchflower
+ chmod a-x assets/app/watchflower.desktop
+ qmake -config release PREFIX=${pkgdir}/usr/
+ make
+}
+
+package() {
+ cd "WatchFlower-${pkgver}"
+ chmod a+x bin/watchflower # 0.1 hacks
+ make install
+}
+