summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Luis Lafuente2015-12-12 17:59:11 +0100
committerJosé Luis Lafuente2015-12-12 17:59:11 +0100
commit13546ca83b71408f86440f5e5566a10d74bbe6b5 (patch)
tree610250ee71aaca4b8989e7958822e19153d244bb
parent60283dfe436cbbb82e380c5f8e05a94502709d05 (diff)
downloadaur-13546ca83b71408f86440f5e5566a10d74bbe6b5.tar.gz
Update to 4.2.0-2
-rw-r--r--.SRCINFO9
-rw-r--r--.gitignore2
-rw-r--r--PKGBUILD21
-rw-r--r--watchman.install11
-rw-r--r--watchman.tmpfiles1
5 files changed, 34 insertions, 10 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 4a84f677f496..86f3f002598f 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,17 +1,20 @@
# Generated by mksrcinfo v8
-# Sat Dec 12 01:49:58 UTC 2015
+# Sat Dec 12 16:57:32 UTC 2015
pkgbase = watchman
pkgdesc = An inotify-based file watching and job triggering command line utility
pkgver = 4.2.0
- pkgrel = 1
+ pkgrel = 2
url = https://facebook.github.io/watchman/
+ install = watchman.install
arch = x86_64
arch = i686
license = Apache
- depends = glibc
+ makedepends = glibc
depends = pcre
source = watchman-4.2.0.tar.gz::https://github.com/facebook/watchman/archive/v4.2.0.tar.gz
+ source = watchman.tmpfiles
sha256sums = d8998df9795951d49dce9df82da11eeba384934d5d9d3f0ea2d543a9837e2ddb
+ sha256sums = 2b061865e10578a0477b9c7991a00594bc839c846b98896e93c75743dbf6a379
pkgname = watchman
diff --git a/.gitignore b/.gitignore
index 87b64657ff3e..a08077cc92f1 100644
--- a/.gitignore
+++ b/.gitignore
@@ -2,4 +2,6 @@
!PKGBUILD
!.SRCINFO
+!watchman.tmpfiles
+!watchman.install
!.gitignore
diff --git a/PKGBUILD b/PKGBUILD
index 8c4e9cade013..f12a79521cb9 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -2,30 +2,37 @@
# Original maintainer: Michael Louis Thaler <michael.louis.thaler@gmail.com>
pkgname=watchman
pkgver=4.2.0
-pkgrel=1
+pkgrel=2
pkgdesc="An inotify-based file watching and job triggering command line utility"
url="https://facebook.github.io/watchman/"
arch=('x86_64' 'i686')
license=('Apache')
-depends=('glibc' 'pcre')
+depends=('pcre')
optdepends=()
-makedepends=()
+makedepends=('glibc')
conflicts=()
replaces=()
backup=()
-source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebook/watchman/archive/v${pkgver}.tar.gz")
-sha256sums=('d8998df9795951d49dce9df82da11eeba384934d5d9d3f0ea2d543a9837e2ddb')
+install=$pkgname.install
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebook/watchman/archive/v${pkgver}.tar.gz"
+ "${pkgname}.tmpfiles")
+
+sha256sums=('d8998df9795951d49dce9df82da11eeba384934d5d9d3f0ea2d543a9837e2ddb'
+ '2b061865e10578a0477b9c7991a00594bc839c846b98896e93c75743dbf6a379')
build() {
cd "${srcdir}/${pkgname}-${pkgver}"
./autogen.sh
- ./configure --prefix=/usr --without-python
+ ./configure --prefix= --exec-prefix=/usr --localstatedir=/run/${pkgname} --without-python
make
}
package() {
cd "${srcdir}/${pkgname}-${pkgver}"
- make DESTDIR="${pkgdir}" install
+ # Docs only online, see https://github.com/facebook/watchman/issues/30
+ make DESTDIR="${pkgdir}" install-binPROGRAMS
+ install -dm 755 "${pkgdir}"/usr/lib/tmpfiles.d
+ install -m 644 "../${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
}
# vim:set ts=2 sw=2 et:
diff --git a/watchman.install b/watchman.install
new file mode 100644
index 000000000000..1bde732dde25
--- /dev/null
+++ b/watchman.install
@@ -0,0 +1,11 @@
+#!/bin/sh
+
+post_install() {
+ systemd-tmpfiles --create watchman.conf
+}
+
+post_upgrade() {
+ systemd-tmpfiles --create watchman.conf
+}
+
+# vim:set ts=2 sw=2 et:
diff --git a/watchman.tmpfiles b/watchman.tmpfiles
new file mode 100644
index 000000000000..3cd974f4a3e6
--- /dev/null
+++ b/watchman.tmpfiles
@@ -0,0 +1 @@
+d /run/watchman 0777 root root