summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJosé Luis Lafuente2015-06-17 10:51:53 +0200
committerJosé Luis Lafuente2015-06-17 10:51:53 +0200
commit7b190dcac3ab5084395ed3d51340881ea4aa5d21 (patch)
treeeeba25cbfd0dcf075330ac2a1500dd0351ea71b4
downloadaur-7b190dcac3ab5084395ed3d51340881ea4aa5d21.tar.gz
Initial import
-rw-r--r--.SRCINFO17
-rw-r--r--PKGBUILD39
2 files changed, 56 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..bab6a51e44ad
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,17 @@
+pkgbase = watchman
+ pkgdesc = An inotify-based file watching and job triggering command line utility
+ pkgver = 3.1
+ pkgrel = 0
+ url = https://facebook.github.io/watchman/
+ arch = x86_64
+ arch = i686
+ license = Apache
+ depends = glibc
+ depends = pcre
+ source = watchman-3.1.tar.gz::https://github.com/facebook/watchman/archive/v3.1.tar.gz
+ source = https://github.com/facebook/watchman/commit/690890143518e0fa507dba10aa98b88d3df8e003.patch
+ sha256sums = c463b5cd5d8ccfbe96bdbcdc5a3c04c91c8eae53e1ffa4846a7317a8f6b4f159
+ sha256sums = d9c0eea3cdff0d1f9fc71720906a4490420c9fc6620271eab6922f875a08761d
+
+pkgname = watchman
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..5da0ec059d05
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,39 @@
+# Maintainer: José Luis Lafuente <jl@lafuente.me>
+# Original maintainer: Michael Louis Thaler <michael.louis.thaler@gmail.com>
+pkgname=watchman
+pkgver=3.1
+pkgrel=0
+_patch="690890143518e0fa507dba10aa98b88d3df8e003"
+pkgdesc="An inotify-based file watching and job triggering command line utility"
+url="https://facebook.github.io/watchman/"
+arch=('x86_64' 'i686')
+license=('Apache')
+depends=('glibc' 'pcre')
+optdepends=()
+makedepends=()
+conflicts=()
+replaces=()
+backup=()
+source=("${pkgname}-${pkgver}.tar.gz::https://github.com/facebook/watchman/archive/v${pkgver}.tar.gz"
+ "https://github.com/facebook/watchman/commit/${_patch}.patch")
+sha256sums=('c463b5cd5d8ccfbe96bdbcdc5a3c04c91c8eae53e1ffa4846a7317a8f6b4f159'
+ 'd9c0eea3cdff0d1f9fc71720906a4490420c9fc6620271eab6922f875a08761d')
+
+prepare() {
+ cd "${srcdir}"
+ patch -p1 -d ${pkgname}-${pkgver} < ${_patch}.patch
+}
+
+build() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ ./autogen.sh
+ ./configure --prefix=/usr
+ make
+}
+
+package() {
+ cd "${srcdir}/${pkgname}-${pkgver}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# vim:set ts=2 sw=2 et: