summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2020-10-06 13:19:19 +0200
committerJan Alexander Steffens (heftig)2020-10-22 17:35:21 +0200
commit8d5d37080b66ee73dc1d4063a91f07c57e1b5c2e (patch)
treeae18af2641f0f629f28e717db97d6e8ef4343e12
downloadaur-8d5d37080b66ee73dc1d4063a91f07c57e1b5c2e.tar.gz
initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD40
2 files changed, 59 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..565c15450b01
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+pkgbase = watchman-bin
+ pkgdesc = An inotify-based file watching and job triggering command line utility
+ pkgver = 2020.09.21.00
+ pkgrel = 1
+ url = https://facebook.github.io/watchman/
+ arch = x86_64
+ license = Apache
+ makedepends = patchelf
+ makedepends = python
+ depends = openssl
+ depends = google-glog
+ depends = gflags
+ provides = watchman=2020.09.21.00
+ conflicts = watchman
+ source = https://github.com/facebook/watchman/releases/download/v2020.09.21.00/watchman-v2020.09.21.00-linux.zip
+ sha256sums = 172a191f14bee5e94fb99ffe9c47983b323c07952fcb9581a55f115e41b0efae
+
+pkgname = watchman-bin
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8b2e043aaba0
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,40 @@
+pkgname=watchman-bin
+pkgver=2020.09.21.00
+pkgrel=1
+pkgdesc="An inotify-based file watching and job triggering command line utility"
+url="https://facebook.github.io/watchman/"
+arch=(x86_64)
+license=(Apache)
+depends=(openssl google-glog gflags)
+makedepends=(patchelf python)
+provides=("watchman=$pkgver")
+conflicts=(watchman)
+source=("https://github.com/facebook/watchman/releases/download/v$pkgver/watchman-v$pkgver-linux.zip")
+sha256sums=('172a191f14bee5e94fb99ffe9c47983b323c07952fcb9581a55f115e41b0efae')
+
+prepare() {
+ python <watchman-v$pkgver-linux/bin/watchman >watchman.hex \
+ -c 'import codecs; open(1, "wb").write(codecs.encode(open(0, "rb").read(), "hex"))'
+
+ # /usr/local/var/run/watchman -> /run/watchman
+ local badpath=2f7573722f6c6f63616c2f7661722f72756e2f77617463686d616e00
+ local goodpath=2f72756e2f77617463686d616e000000000000000000000000000000
+ sed -i "s/$badpath/$goodpath/g" watchman.hex
+
+ python <watchman.hex >watchman \
+ -c 'import codecs; open(1, "wb").write(codecs.decode(open(0, "rb").read(), "hex"))'
+
+ patchelf \
+ --replace-needed /usr/local/lib/libgflags.so.2.2 libgflags.so.2.2 \
+ --replace-needed /usr/local/lib/libglog.so.0 libglog.so.0 \
+ watchman
+}
+
+package() {
+ install -Dt "$pkgdir/usr/bin" watchman
+ install -Dm644 /dev/stdin "$pkgdir"/usr/lib/tmpfiles.d/watchman.conf <<END
+d /run/watchman 0777 root root
+END
+}
+
+# vim:set sw=2 et: