summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorJan Alexander Steffens (heftig)2022-05-14 02:49:58 +0200
committerJan Alexander Steffens (heftig)2022-05-14 02:49:58 +0200
commite5c0e8d18b9f2ad0e36e7342f527c6fdd7979cf7 (patch)
treede61eea42b802ac44e75af113dd81e6c89286011
parente9c8af488ec5f0c4ed43533e3108eb525b5b2821 (diff)
downloadaur-e5c0e8d18b9f2ad0e36e7342f527c6fdd7979cf7.tar.gz
Work around a crash with recent libgcc
See: https://github.com/facebook/watchman/issues/1019
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD10
-rw-r--r--libgcc_s.so.1bin0 -> 478272 bytes
3 files changed, 10 insertions, 2 deletions
diff --git a/.SRCINFO b/.SRCINFO
index ff868c9f2479..733cd16cf0d7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -14,6 +14,8 @@ pkgbase = watchman-bin
conflicts = watchman
options = !strip
source = https://github.com/facebook/watchman/releases/download/v2022.05.09.00/watchman-v2022.05.09.00-linux.zip
+ source = libgcc_s.so.1
sha256sums = 99a4aad800d7ecd6d5d265d40ee3633f5afc1c3c97eaed4a443e72cdef1091f3
+ sha256sums = a82367caaa653296b67007e5db6aa3a7a8103687690cdfa91a0095dacff8cbea
pkgname = watchman-bin
diff --git a/PKGBUILD b/PKGBUILD
index f07adcc4cdc1..6a8e1f81c20b 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -15,8 +15,10 @@ options=(!strip)
install=watchman.install
# https://github.com/facebook/watchman/releases
-source=("https://github.com/facebook/watchman/releases/download/v$pkgver/watchman-v$pkgver-linux.zip")
-sha256sums=('99a4aad800d7ecd6d5d265d40ee3633f5afc1c3c97eaed4a443e72cdef1091f3')
+source=("https://github.com/facebook/watchman/releases/download/v$pkgver/watchman-v$pkgver-linux.zip"
+ libgcc_s.so.1)
+sha256sums=('99a4aad800d7ecd6d5d265d40ee3633f5afc1c3c97eaed4a443e72cdef1091f3'
+ 'a82367caaa653296b67007e5db6aa3a7a8103687690cdfa91a0095dacff8cbea')
prepare() {
cd watchman-v$pkgver-linux
@@ -52,6 +54,10 @@ package() {
install -Dt "$pkgdir/usr/bin" bin/*
install -Dt "$pkgdir/usr/lib/watchman" lib/*
+ # Add libgcc from gcc-libs 11.2.0-4 to avoid a crash
+ # https://github.com/facebook/watchman/issues/1019
+ install -t "$pkgdir/usr/lib/watchman" ../libgcc_s.so.1
+
install -Dm644 /dev/stdin "$pkgdir/usr/lib/tmpfiles.d/watchman.conf" <<END
d /run/watchman 1777 root root
END
diff --git a/libgcc_s.so.1 b/libgcc_s.so.1
new file mode 100644
index 000000000000..bcf89950a86e
--- /dev/null
+++ b/libgcc_s.so.1
Binary files differ