summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMario Rodas2015-12-12 11:17:43 -0500
committerMario Rodas2015-12-12 11:17:43 -0500
commit18d92627213e9e385b36e2b2ad36d063410e0f0b (patch)
tree5503318ae0863e335b596935c05033e1352fc30c
downloadaur-18d92627213e9e385b36e2b2ad36d063410e0f0b.tar.gz
Initial commit
-rw-r--r--.SRCINFO19
-rw-r--r--PKGBUILD46
2 files changed, 65 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..6f380cd532c8
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,19 @@
+# Generated by mksrcinfo v8
+# Sat Dec 12 15:53:11 UTC 2015
+pkgbase = watchman-git
+ pkgdesc = Watches files and records, or triggers actions, when they change.
+ pkgver = r717.a75b2b8
+ pkgrel = 1
+ url = https://facebook.github.io/watchman/
+ arch = i686
+ arch = x86_64
+ license = Apache
+ makedepends = git
+ depends = pcre
+ options = !libtool
+ options = staticlibs
+ source = watchman::git+https://github.com/facebook/watchman.git
+ sha256sums = SKIP
+
+pkgname = watchman-git
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..29867dbbbe1e
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,46 @@
+# Maintainer: Mario Rodas <marsam@users.noreply.github.com>
+
+pkgname=watchman-git
+_gitname=watchman
+pkgver=r717.a75b2b8
+pkgrel=1
+pkgdesc='Watches files and records, or triggers actions, when they change.'
+arch=('i686' 'x86_64')
+url='https://facebook.github.io/watchman/'
+license=('Apache')
+depends=('pcre')
+makedepends=('git')
+conflicts=()
+options=('!libtool' 'staticlibs')
+provides=()
+source=("${_gitname}::git+https://github.com/facebook/watchman.git")
+sha256sums=('SKIP')
+
+pkgver() {
+ cd "${srcdir}/${_gitname}"
+ printf "r%s.%s" "$(git rev-list --count HEAD)" "$(git rev-parse --short HEAD)"
+}
+
+build() {
+ cd "${srcdir}/${_gitname}"
+ ./autogen.sh
+ ./configure --prefix=/usr \
+ --with-pcre \
+ --without-python \
+ --enable-statedir="/var/lib/${_gitname}"
+ make
+}
+
+check() {
+ cd "${srcdir}/${_gitname}"
+ make check
+}
+
+package() {
+ cd "${srcdir}/${_gitname}"
+ make DESTDIR="${pkgdir}" install
+}
+
+# Local Variables:
+# compile-command: "makepkg -sm && mksrcinfo"
+# End: