summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrandom-nick2020-08-21 23:55:30 +0200
committerrandom-nick2020-08-21 23:55:30 +0200
commit163e785d4236f6fc80fe91b50ff47d62c20823f0 (patch)
tree7269361ce36c2e7e45b557b5be6624f4226b700a
parenteb0ffb33c834aad48bb57b0d9ff11ad19c0cd336 (diff)
downloadaur-163e785d4236f6fc80fe91b50ff47d62c20823f0.tar.gz
Correct makedepends and optdepends
Thank you to AUR user ccorn for spotting the missing optdepends.
-rw-r--r--.SRCINFO9
-rw-r--r--PKGBUILD15
2 files changed, 12 insertions, 12 deletions
diff --git a/.SRCINFO b/.SRCINFO
index eeddd839b2f5..989338fe25c7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = waterfox
pkgdesc = Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch.
pkgver = 2020.07.2.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.waterfox.net/
arch = x86_64
license = MPL
@@ -20,12 +20,14 @@ pkgbase = waterfox
makedepends = rust
makedepends = clang
makedepends = llvm
+ makedepends = lld
makedepends = jack
makedepends = python
makedepends = nodejs
makedepends = python2-psutil
makedepends = cbindgen
makedepends = nasm
+ makedepends = libpulse
depends = gtk3
depends = gtk2
depends = libxt
@@ -34,10 +36,9 @@ pkgbase = waterfox
depends = dbus-glib
depends = nss
depends = ttf-font
- optdepends = networkmanager: Location detection via available WiFi networks
optdepends = libnotify: Notification integration
- optdepends = pulseaudio: Audio support
- optdepends = libpulse: Audio support
+ optdepends = libpulse: Audio support via Pulseaudio
+ optdepends = jack: Audio support via JACK
optdepends = ffmpeg: Multimedia playback
optdepends = speech-dispatcher: Text-to-Speech
optdepends = hunspell-en_US: Spell checking, American English
diff --git a/PKGBUILD b/PKGBUILD
index 2d5ee29e5966..953bd512149a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,20 +6,19 @@
pkgname=waterfox
pkgver=2020.07.2.1
-pkgrel=1
+pkgrel=2
pkgdesc="Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch."
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.waterfox.net/"
depends=(gtk3 gtk2 libxt startup-notification mime-types dbus-glib nss ttf-font)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
- xorg-server-xvfb autoconf2.13 rust clang llvm jack
- python nodejs python2-psutil cbindgen nasm)
-optdepends=('networkmanager: Location detection via available WiFi networks'
- 'libnotify: Notification integration'
- 'pulseaudio: Audio support'
- 'libpulse: Audio support'
- 'ffmpeg: Multimedia playback'
+ xorg-server-xvfb autoconf2.13 rust clang llvm lld jack
+ python nodejs python2-psutil cbindgen nasm libpulse)
+optdepends=('libnotify: Notification integration'
+ 'libpulse: Audio support via Pulseaudio'
+ 'jack: Audio support via JACK'
+ 'ffmpeg: Multimedia playback'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)