summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorNicola Revelant2023-11-15 22:49:24 +0100
committerNicola Revelant2023-11-15 22:49:24 +0100
commit3932f2b260730f0f20ecd67a07306ce9ad19ba48 (patch)
tree83c98813e8cc5810b8eabdfb336929f739a07040
parent639bc22c6afa4e87ce29eefff4fb38d382b75e6c (diff)
downloadaur-3932f2b260730f0f20ecd67a07306ce9ad19ba48.tar.gz
Version G6.0.5
-rw-r--r--.SRCINFO12
-rw-r--r--.gitignore6
-rw-r--r--PKGBUILD221
3 files changed, 113 insertions, 126 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 24f59735e133..7ebcdae55921 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waterfox
pkgdesc = Fork of Mozilla Firefox featuring some privacy, usability, and speed enhancements.
- pkgver = G5.1.7
+ pkgver = G6.0.5
pkgrel = 1
url = https://www.waterfox.net/
arch = x86_64
@@ -12,7 +12,6 @@ pkgbase = waterfox
makedepends = diffutils
makedepends = dump_syms
makedepends = imake
- makedepends = inetutils
makedepends = jack
makedepends = lld
makedepends = llvm
@@ -27,15 +26,12 @@ pkgbase = waterfox
makedepends = wasi-libc
makedepends = wasi-libc++
makedepends = wasi-libc++abi
- makedepends = xorg-server-xvfb
makedepends = yasm
makedepends = zip
- depends = dbus-glib
- depends = ffmpeg
depends = gtk3
- depends = libpulse
depends = libxt
depends = mime-types
+ depends = dbus-glib
depends = nss
depends = ttf-font
optdepends = hunspell-en_US: Spell checking, American English
@@ -47,9 +43,9 @@ pkgbase = waterfox
options = !emptydirs
options = !makeflags
options = !strip
- source = G5.1.7.tar.gz::https://github.com/WaterfoxCo/Waterfox/archive/refs/tags/G5.1.7.tar.gz.tar.gz
+ source = waterfox-G6.0.5.tar.gz::https://github.com/WaterfoxCo/Waterfox/archive/refs/tags/G6.0.5.tar.gz
source = waterfox.desktop
- sha256sums = 2f46c035e87d5fe565ec7009154bf9b356e7dd569377cf1662ba875b6679988c
+ sha256sums = 16ebb539fd696bd4337641d0b5e9e871c69a31971d7a12bb4efa3b9f79034041
sha256sums = 3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3
pkgname = waterfox
diff --git a/.gitignore b/.gitignore
index 4c5f17df919e..72e8ffc0db8a 100644
--- a/.gitignore
+++ b/.gitignore
@@ -1,5 +1 @@
-src
-Waterfox-*
-*.tar.gz
-*.tar.bz2
-pkg \ No newline at end of file
+*
diff --git a/PKGBUILD b/PKGBUILD
index dbc2f3ace83c..de2f3fb4c1df 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,4 +1,5 @@
-# Maintainer: Cyra Westmere <cyra@slowest.network>
+# Maintainer: Nicola Revelant <nicolarevelant@outlook.com>
+# Contributor: Cyra Westmere <cyra@slowest.network>
# Contributor: random-nick <random-nick@email.com>
# Based on the official firefox package by:
# Contributor: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
@@ -6,72 +7,68 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=waterfox
-pkgver=G5.1.7
+pkgver=G6.0.5
pkgrel=1
pkgdesc="Fork of Mozilla Firefox featuring some privacy, usability, and speed enhancements."
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.waterfox.net/"
depends=(
- gtk3
- gtk2
- libxt
- mime-types
- dbus-glib
- nss
- ttf-font
+ gtk3
+ libxt
+ mime-types
+ dbus-glib
+ nss
+ ttf-font
)
makedepends=(
- cbindgen
- clang
- diffutils
- dump_syms
- imake
- inetutils
- jack
- lld
- llvm
- mercurial
- mesa
- nasm
- nodejs
- python
- rust
- unzip
- wasi-compiler-rt
- wasi-libc
- wasi-libc++
- wasi-libc++abi
- xorg-server-xvfb
- yasm
- zip
+ cbindgen
+ clang
+ diffutils
+ dump_syms
+ imake
+ jack
+ lld
+ llvm
+ mercurial
+ mesa
+ nasm
+ nodejs
+ python
+ rust
+ unzip
+ wasi-compiler-rt
+ wasi-libc
+ wasi-libc++
+ wasi-libc++abi
+ yasm
+ zip
)
optdepends=(
- 'hunspell-en_US: Spell checking, American English'
- 'libnotify: Notification integration'
- 'networkmanager: Location detection via available WiFi networks'
- 'pulseaudio: Audio support'
- 'speech-dispatcher: Text-to-Speech'
- 'xdg-desktop-portal: Screensharing with Wayland'
+ 'hunspell-en_US: Spell checking, American English'
+ 'libnotify: Notification integration'
+ 'networkmanager: Location detection via available WiFi networks'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech'
+ 'xdg-desktop-portal: Screensharing with Wayland'
)
options=(!emptydirs !makeflags !strip)
-_archiveversion=G5.1.7
source=(
- $_archiveversion.tar.gz::https://github.com/WaterfoxCo/Waterfox/archive/refs/tags/$_archiveversion.tar.gz
- $pkgname.desktop
+ $pkgname-$pkgver.tar.gz::https://github.com/WaterfoxCo/Waterfox/archive/refs/tags/$pkgver.tar.gz
+ $pkgname.desktop
)
sha256sums=(
- '2f46c035e87d5fe565ec7009154bf9b356e7dd569377cf1662ba875b6679988c'
- '3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3'
+ '16ebb539fd696bd4337641d0b5e9e871c69a31971d7a12bb4efa3b9f79034041'
+ '3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3'
)
prepare () {
- mkdir -p mozbuild
- cd Waterfox-$_archiveversion
+ mkdir -p mozbuild
+ cd "Waterfox-$pkgver"
- cat >../mozconfig <<EOT
+ cat > ../mozconfig <<EOT
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
ac_add_options --enable-application=browser
@@ -108,69 +105,69 @@ EOT
}
build () {
- cd Waterfox-$_archiveversion
+ cd Waterfox-$pkgver
- export MOZ_NOSPAM=1
- export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
- export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=none
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+ export MACH_BUILD_PYTHON_NATIVE_PACKAGE_SOURCE=none
- # LTO needs more open files
- ulimit -n 4096
+ # LTO needs more open files
+ ulimit -n 4096
- # prevents references to $srcdir being included in error messages
- # some references still remain in libxul.so and omni.ja
- CFLAGS+=" -ffile-prefix-map=$srcdir=."
- CXXFLAGS+=" -ffile-prefix-map=$srcdir=."
+ # prevents references to $srcdir being included in error messages
+ # some references still remain in libxul.so and omni.ja
+ CFLAGS+=" -ffile-prefix-map=$srcdir=."
+ CXXFLAGS+=" -ffile-prefix-map=$srcdir=."
- # suppress warnings
- CFLAGS+=" -w"
- CXXFLAGS+=" -w"
+ # suppress warnings
+ CFLAGS+=" -w"
+ CXXFLAGS+=" -w"
#_disable_pgo=y # uncomment this to disable building the profiled browser and using PGO
- if [[ -z $_disable_pgo ]]; then
+ if [[ -z $_disable_pgo ]]; then
# Do 3-tier PGO
- echo "Building instrumented browser..."
- cat >.mozconfig ../mozconfig - <<EOT
+ echo "Building instrumented browser..."
+ cat >.mozconfig ../mozconfig - <<EOT
ac_add_options --enable-profile-generate=cross
EOT
- ./mach build
+ ./mach build
- echo "Profiling instrumented browser..."
- ./mach package
- LLVM_PROFDATA=llvm-profdata \
- JARLOG_FILE="$PWD/jarlog" \
- xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
- ./mach python build/pgo/profileserver.py
+ echo "Profiling instrumented browser..."
+ ./mach package
+ LLVM_PROFDATA=llvm-profdata \
+ JARLOG_FILE="$PWD/jarlog" \
+ xvfb-run -s "-screen 0 1920x1080x24 -nolisten local" \
+ ./mach python build/pgo/profileserver.py
- stat -c "Profile data found (%s bytes)" merged.profdata
- test -s merged.profdata
+ stat -c "Profile data found (%s bytes)" merged.profdata
+ test -s merged.profdata
- stat -c "Jar log found (%s bytes)" jarlog
- test -s jarlog
+ stat -c "Jar log found (%s bytes)" jarlog
+ test -s jarlog
- echo "Removing instrumented browser..."
- ./mach clobber
+ echo "Removing instrumented browser..."
+ ./mach clobber
- echo "Building optimized browser..."
- cat >.mozconfig ../mozconfig - <<EOT
+ echo "Building optimized browser..."
+ cat >.mozconfig ../mozconfig - <<EOT
ac_add_options --enable-lto=cross
ac_add_options --enable-profile-use=cross
ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
EOT
else
- ./mach build
+ ./mach build
- echo "Building symbol archive..."
- ./mach buildsymbols
+ echo "Building symbol archive..."
+ ./mach buildsymbols
fi
}
package () {
- cd Waterfox-$_archiveversion
- DESTDIR="$pkgdir" ./mach install
+ cd Waterfox-$pkgver
+ DESTDIR="$pkgdir" ./mach install
- local vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
- install -Dvm644 /dev/stdin "$vendorjs" <<EOT
+ local vendorjs="$pkgdir/usr/lib/$pkgname/browser/defaults/preferences/vendor.js"
+ install -Dvm644 /dev/stdin "$vendorjs" <<EOT
// Use LANG environment variable to choose locale
pref("intl.locale.requested", "");
@@ -184,8 +181,8 @@ pref("browser.shell.checkDefaultBrowser", false);
pref("extensions.autoDisableScopes", 11);
EOT
- local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
- install -Dvm644 /dev/stdin "$distini" <<EOT
+ local distini="$pkgdir/usr/lib/$pkgname/distribution/distribution.ini"
+ install -Dvm644 /dev/stdin "$distini" <<EOT
[Global]
id=archlinux
version=1.0
@@ -196,36 +193,34 @@ app.distributor=archlinux
app.distributor.channel=$pkgname
EOT
- local i theme=waterfox
- for i in 16 22 24 32 48 64 128 256; do
- install -Dvm644 browser/branding/$theme/default$i.png \
- "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
- done
- install -Dvm644 browser/branding/$theme/content/about-logo.png \
- "$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
- install -Dvm644 browser/branding/$theme/content/about-logo@2x.png \
- "$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
- install -Dvm644 browser/branding/$theme/content/identity-icons-brand.svg \
- "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
-
- install -Dvm644 ../$pkgname.desktop \
- "$pkgdir/usr/share/applications/$pkgname.desktop"
-
- # Install a wrapper to avoid confusion about binary path
- install -Dvm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<EOT
+ local i theme=waterfox
+ for i in 16 22 24 32 48 64 128 256; do
+ install -Dvm644 browser/branding/$theme/default$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/$pkgname.png"
+ done
+ install -Dvm644 browser/branding/$theme/content/about-logo.png \
+ "$pkgdir/usr/share/icons/hicolor/192x192/apps/$pkgname.png"
+ install -Dvm644 browser/branding/$theme/content/about-logo@2x.png \
+ "$pkgdir/usr/share/icons/hicolor/384x384/apps/$pkgname.png"
+ install -Dvm644 browser/branding/$theme/content/identity-icons-brand.svg \
+ "$pkgdir/usr/share/icons/hicolor/symbolic/apps/$pkgname-symbolic.svg"
+
+ install -Dvm644 ../$pkgname.desktop \
+ "$pkgdir/usr/share/applications/$pkgname.desktop"
+
+ # Install a wrapper to avoid confusion about binary path
+ install -Dvm755 /dev/stdin "$pkgdir/usr/bin/$pkgname" <<EOT
#!/usr/bin/env sh
exec /usr/lib/$pkgname/waterfox "\$@"
EOT
- # Replace duplicate binary with wrapper
- # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
- ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/waterfox-bin"
+ # Replace duplicate binary with wrapper
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=658850
+ ln -srfv "$pkgdir/usr/bin/$pkgname" "$pkgdir/usr/lib/$pkgname/waterfox-bin"
- # Use system certificates
- local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"
- if [[ -e $nssckbi ]]; then
- ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
- fi
+ # Use system certificates
+ local nssckbi="$pkgdir/usr/lib/$pkgname/libnssckbi.so"
+ if [[ -e $nssckbi ]]; then
+ ln -srfv "$pkgdir/usr/lib/libnssckbi.so" "$nssckbi"
+ fi
}
-
-# vim:set ts=2 sw=2 et: