summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrandom-nick2021-02-05 14:26:40 +0100
committerrandom-nick2021-02-05 14:26:40 +0100
commitbf769d6c6bf8e641635d202a6d528d0427cdcc12 (patch)
tree6bf8219f584b9f47ca6b0a1de2933d1be6908b8f
parent61737e6484e4bf6431d34fbfda194b51ad0217ca (diff)
downloadaur-bf769d6c6bf8e641635d202a6d528d0427cdcc12.tar.gz
G3.1.0
-rw-r--r--.SRCINFO13
-rw-r--r--0001-Use-remoting-name-for-GDK-application-names.patch56
-rw-r--r--0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch46
-rw-r--r--0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch31
-rw-r--r--PKGBUILD33
5 files changed, 73 insertions, 106 deletions
diff --git a/.SRCINFO b/.SRCINFO
index c1b6f434bf6c..12981a0d8399 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waterfox
pkgdesc = Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch.
- pkgver = 2020.10
+ pkgver = G3.1.0
pkgrel = 1
url = https://www.waterfox.net/
arch = x86_64
@@ -31,7 +31,6 @@ pkgbase = waterfox
depends = gtk3
depends = gtk2
depends = libxt
- depends = startup-notification
depends = mime-types
depends = dbus-glib
depends = nss
@@ -45,14 +44,12 @@ pkgbase = waterfox
options = !emptydirs
options = !makeflags
options = !strip
- source = Waterfox-2020.10-current.tar.gz::https://github.com/MrAlex94/Waterfox/archive/2020.10-current.tar.gz
+ source = Waterfox-G3.1.0.tar.gz::https://github.com/MrAlex94/Waterfox/archive/G3.1.0.tar.gz
source = waterfox.desktop
- source = 0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
- source = 0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
- sha256sums = 5958cbe5df3de971915a457c913a0af9280eee03e4a86ee675e844d4c3254db3
+ source = 0001-Use-remoting-name-for-GDK-application-names.patch
+ sha256sums = 53cb509512b789e335ecbaf3475c8fc4dd18b0eb87aec9e576ac2078c749f196
sha256sums = 3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3
- sha256sums = c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29
- sha256sums = 52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc
+ sha256sums = 1dba448eb1605c9dc73c22861a5394b50055909399f056baee4887b29af1b51e
pkgname = waterfox
diff --git a/0001-Use-remoting-name-for-GDK-application-names.patch b/0001-Use-remoting-name-for-GDK-application-names.patch
new file mode 100644
index 000000000000..c97bfdfd8ddc
--- /dev/null
+++ b/0001-Use-remoting-name-for-GDK-application-names.patch
@@ -0,0 +1,56 @@
+From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
+From: "Jan Alexander Steffens (heftig)" <jan.steffens@gmail.com>
+Date: Mon, 25 Mar 2019 20:30:11 +0100
+Subject: [PATCH] Use remoting name for GDK application names
+
+---
+ toolkit/xre/nsAppRunner.cpp | 6 +-----
+ widget/gtk/nsAppShell.cpp | 11 ++++-------
+ 2 files changed, 5 insertions(+), 12 deletions(-)
+
+diff --git a/toolkit/xre/nsAppRunner.cpp b/toolkit/xre/nsAppRunner.cpp
+index a16521852d05..d0be5a088d8c 100644
+--- a/toolkit/xre/nsAppRunner.cpp
++++ b/toolkit/xre/nsAppRunner.cpp
+@@ -3832,11 +3832,7 @@ int XREMain::XRE_mainStartup(bool* aExitFlag) {
+ // consistently.
+
+ // Set program name to the one defined in application.ini.
+- {
+- nsAutoCString program(gAppData->name);
+- ToLowerCase(program);
+- g_set_prgname(program.get());
+- }
++ g_set_prgname(gAppData->remotingName);
+
+ // Initialize GTK here for splash.
+
+diff --git a/widget/gtk/nsAppShell.cpp b/widget/gtk/nsAppShell.cpp
+index cfe022e65d82..06325264dbb1 100644
+--- a/widget/gtk/nsAppShell.cpp
++++ b/widget/gtk/nsAppShell.cpp
+@@ -24,6 +24,7 @@
+ # include "WakeLockListener.h"
+ #endif
+ #include "gfxPlatform.h"
++#include "nsAppRunner.h"
+ #include "ScreenHelperGTK.h"
+ #include "HeadlessScreenHelper.h"
+ #include "mozilla/widget/ScreenManager.h"
+@@ -159,13 +160,9 @@ nsresult nsAppShell::Init() {
+ // See https://bugzilla.gnome.org/show_bug.cgi?id=747634
+ //
+ // Only bother doing this for the parent process, since it's the one
+- // creating top-level windows. (At this point, a child process hasn't
+- // received the list of registered chrome packages, so the
+- // GetBrandShortName call would fail anyway.)
+- nsAutoString brandName;
+- mozilla::widget::WidgetUtils::GetBrandShortName(brandName);
+- if (!brandName.IsEmpty()) {
+- gdk_set_program_class(NS_ConvertUTF16toUTF8(brandName).get());
++ // creating top-level windows.
++ if (gAppData) {
++ gdk_set_program_class(gAppData->remotingName);
+ }
+ }
+ }
diff --git a/0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch b/0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
deleted file mode 100644
index 427dfcdc1e00..000000000000
--- a/0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
+++ /dev/null
@@ -1,46 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Jed Davis <jld@mozilla.com>
-Date: Fri, 28 Aug 2020 09:23:58 +0000
-Subject: [PATCH] Bug 1660901 - Support the fstat-like subset of fstatat in the
- Linux sandbox policies. r=gcp
-
-Differential Revision: https://phabricator.services.mozilla.com/D88499
----
- security/sandbox/linux/SandboxFilter.cpp | 6 ++++++
- security/sandbox/linux/broker/SandboxBrokerUtils.h | 2 ++
- 2 files changed, 8 insertions(+)
-
-diff --git a/security/sandbox/linux/SandboxFilter.cpp b/security/sandbox/linux/SandboxFilter.cpp
-index e522d61e065c..4087bdc07e01 100644
---- a/security/sandbox/linux/SandboxFilter.cpp
-+++ b/security/sandbox/linux/SandboxFilter.cpp
-@@ -243,6 +243,12 @@ class SandboxPolicyCommon : public SandboxPolicyBase {
- auto path = reinterpret_cast<const char*>(aArgs.args[1]);
- auto buf = reinterpret_cast<statstruct*>(aArgs.args[2]);
- auto flags = static_cast<int>(aArgs.args[3]);
-+
-+ if (fd != AT_FDCWD && (flags & AT_EMPTY_PATH) != 0 &&
-+ strcmp(path, "") == 0) {
-+ return ConvertError(fstatsyscall(fd, buf));
-+ }
-+
- if (fd != AT_FDCWD && path[0] != '/') {
- SANDBOX_LOG_ERROR("unsupported fd-relative fstatat(%d, \"%s\", %p, %d)",
- fd, path, buf, flags);
-diff --git a/security/sandbox/linux/broker/SandboxBrokerUtils.h b/security/sandbox/linux/broker/SandboxBrokerUtils.h
-index 85a006740c2c..db33b5028e77 100644
---- a/security/sandbox/linux/broker/SandboxBrokerUtils.h
-+++ b/security/sandbox/linux/broker/SandboxBrokerUtils.h
-@@ -19,10 +19,12 @@
- typedef struct stat64 statstruct;
- # define statsyscall stat64
- # define lstatsyscall lstat64
-+# define fstatsyscall fstat64
- #elif defined(__NR_stat)
- typedef struct stat statstruct;
- # define statsyscall stat
- # define lstatsyscall lstat
-+# define fstatsyscall fstat
- #else
- # error Missing stat syscall include.
- #endif
diff --git a/0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch b/0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
deleted file mode 100644
index dd5a535359a0..000000000000
--- a/0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-From 0000000000000000000000000000000000000000 Mon Sep 17 00:00:00 2001
-From: Julien Cristau <jcristau@mozilla.com>
-Date: Sun, 6 Sep 2020 20:20:39 +0000
-Subject: [PATCH] Bug 1660901 - ignore AT_NO_AUTOMOUNT in fstatat system call.
- r=jld
-
-Per the manpage "Both stat() and lstat() act as though AT_NO_AUTOMOUNT
-was set.", so don't bail if it's set in a call to fstatat.
-
-Differential Revision: https://phabricator.services.mozilla.com/D89121
----
- security/sandbox/linux/SandboxFilter.cpp | 5 +++--
- 1 file changed, 3 insertions(+), 2 deletions(-)
-
-diff --git a/security/sandbox/linux/SandboxFilter.cpp b/security/sandbox/linux/SandboxFilter.cpp
-index 4087bdc07e01..c4f6c318ad1c 100644
---- a/security/sandbox/linux/SandboxFilter.cpp
-+++ b/security/sandbox/linux/SandboxFilter.cpp
-@@ -254,9 +254,10 @@ class SandboxPolicyCommon : public SandboxPolicyBase {
- fd, path, buf, flags);
- return BlockedSyscallTrap(aArgs, nullptr);
- }
-- if ((flags & ~AT_SYMLINK_NOFOLLOW) != 0) {
-+ if ((flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)) != 0) {
- SANDBOX_LOG_ERROR("unsupported flags %d in fstatat(%d, \"%s\", %p, %d)",
-- (flags & ~AT_SYMLINK_NOFOLLOW), fd, path, buf, flags);
-+ (flags & ~(AT_SYMLINK_NOFOLLOW | AT_NO_AUTOMOUNT)), fd,
-+ path, buf, flags);
- return BlockedSyscallTrap(aArgs, nullptr);
- }
- return (flags & AT_SYMLINK_NOFOLLOW) == 0 ? broker->Stat(path, buf)
diff --git a/PKGBUILD b/PKGBUILD
index c8a037102bcc..c402d21a2fb7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,13 +5,13 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=waterfox
-pkgver=2020.10
+pkgver=G3.1.0
pkgrel=1
pkgdesc="Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch."
arch=(x86_64)
license=(MPL GPL LGPL)
url="https://www.waterfox.net/"
-depends=(gtk3 gtk2 libxt startup-notification mime-types dbus-glib nss ttf-font)
+depends=(gtk3 gtk2 libxt mime-types dbus-glib nss ttf-font)
makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
xorg-server-xvfb autoconf2.13 rust clang llvm lld jack
python nodejs python2-psutil cbindgen nasm libpulse)
@@ -22,28 +22,21 @@ optdepends=('libnotify: Notification integration'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
-_archivename=2020.10-current # patch releases don't follow the same format so we can't use $pkgver
+_archivename=G3.1.0 # patch releases don't follow the same format so we can't use $pkgver
source=(Waterfox-$_archivename.tar.gz::https://github.com/MrAlex94/Waterfox/archive/$_archivename.tar.gz
$pkgname.desktop
- 0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
- 0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch)
-sha256sums=('5958cbe5df3de971915a457c913a0af9280eee03e4a86ee675e844d4c3254db3'
+ 0001-Use-remoting-name-for-GDK-application-names.patch)
+sha256sums=('53cb509512b789e335ecbaf3475c8fc4dd18b0eb87aec9e576ac2078c749f196'
'3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3'
- 'c2489a4ad3bfb65c064e07180a1de9a2fbc3b1b72d6bc4cd3985484d1b6b7b29'
- '52cc26cda4117f79fae1a0ad59e1404b299191a1c53d38027ceb178dab91f3dc')
+ '1dba448eb1605c9dc73c22861a5394b50055909399f056baee4887b29af1b51e')
#_disable_pgo=y # uncomment this to disable building the profiled browser and using PGO
prepare() {
mkdir -p mozbuild
cd Waterfox-$_archivename
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
- #patch -Np1 -i ../bug1654465.diff
-
- # https://bugs.archlinux.org/task/67978
- # https://bugzilla.mozilla.org/show_bug.cgi?id=1660901
- patch -Np1 -i ../0002-Bug-1660901-Support-the-fstat-like-subset-of-fstatat.patch
- patch -Np1 -i ../0003-Bug-1660901-ignore-AT_NO_AUTOMOUNT-in-fstatat-system.patch
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1530052
+ patch -Np1 -i ../0001-Use-remoting-name-for-GDK-application-names.patch
cat >../mozconfig <<END
mk_add_options MOZ_OBJDIR=${PWD@Q}/obj
@@ -55,6 +48,7 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+ac_add_options --disable-elf-hack
ac_add_options --enable-linker=lld
export CC='clang --target=x86_64-unknown-linux-gnu'
export CXX='clang++ --target=x86_64-unknown-linux-gnu'
@@ -75,12 +69,9 @@ ac_add_options --with-branding=browser/branding/waterfox
# Features
ac_add_options --enable-alsa
ac_add_options --enable-jack
-ac_add_options --enable-startup-notification
ac_add_options --enable-crashreporter
-ac_add_options --disable-gconf
ac_add_options --disable-updater
ac_add_options --disable-tests
-ac_add_options --disable-elf-hack
END
}
@@ -107,7 +98,7 @@ build() {
# Do 3-tier PGO
echo "Building instrumented browser..."
cat >.mozconfig ../mozconfig - <<END
-ac_add_options --enable-profile-generate
+ac_add_options --enable-profile-generate=cross
END
./mach build
./mach package
@@ -141,8 +132,8 @@ END
echo "Building optimized browser..."
cat >.mozconfig ../mozconfig - <<END
ac_add_options --enable-lto=cross
-ac_add_options --enable-profile-use
-ac_add_options --with-pgo-profile-path=${PWD@Q}/
+ac_add_options --enable-profile-use=cross
+ac_add_options --with-pgo-profile-path=${PWD@Q}/merged.profdata
ac_add_options --with-pgo-jarlog=${PWD@Q}/jarlog
END
else