summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorrandom-nick2020-08-01 20:41:05 +0200
committerrandom-nick2020-08-01 20:41:05 +0200
commite2d5a9fa5273f6d64e97a7196e6fd515493e83a4 (patch)
treed5417ebabfd168ec074cb80de79ef04095e857f4
parentd836b578a4bbc1567f15a2c3b4b4855b018c036a (diff)
downloadaur-e2d5a9fa5273f6d64e97a7196e6fd515493e83a4.tar.gz
2020.07.1-1
Also backported a patch from the firefox PKGBUILD to fix LTO
-rw-r--r--.SRCINFO8
-rw-r--r--PKGBUILD16
-rw-r--r--bug1654465.diff78
3 files changed, 94 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 45b92b7eae56..c0dfe3e1c6e7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,6 +1,6 @@
pkgbase = waterfox
pkgdesc = Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch.
- pkgver = 2020.07
+ pkgver = 2020.07.1
pkgrel = 1
url = https://www.waterfox.net/
arch = x86_64
@@ -44,10 +44,12 @@ pkgbase = waterfox
options = !emptydirs
options = !makeflags
options = !strip
- source = Waterfox-2020.07-current.tar.gz::https://github.com/MrAlex94/Waterfox/archive/2020.07-current.tar.gz
+ source = Waterfox-2020.07.1-current.tar.gz::https://github.com/MrAlex94/Waterfox/archive/2020.07.1-current.tar.gz
source = waterfox.desktop
- sha256sums = 150f46733f1ae28d9ea0b0840069a4080e637a24c49863b81dade3f26ea514bd
+ source = bug1654465.diff
+ sha256sums = 71be464bd6c593245a237a43f2e125a4e7dd45f8f6c96528d478ce2af150bc42
sha256sums = 3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3
+ sha256sums = 4d181c76060845048092724b2fc6f0c2aa76db543c9ba3490f313651de6bb97d
pkgname = waterfox
diff --git a/PKGBUILD b/PKGBUILD
index 990692231d2a..d65a42f9f7b7 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -5,7 +5,7 @@
# Contributor: Jakub Schmidtke <sjakub@gmail.com>
pkgname=waterfox
-pkgver=2020.07
+pkgver=2020.07.1
pkgrel=1
pkgdesc="Fork of Mozilla Firefox featuring some legacy extensions, removed telemetry and no Pocket integration. This is the Current branch."
arch=(x86_64)
@@ -23,16 +23,21 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'speech-dispatcher: Text-to-Speech'
'hunspell-en_US: Spell checking, American English')
options=(!emptydirs !makeflags !strip)
-_archivename=2020.07-current # patch releases don't follow the same format so we can't use $pkgver
+_archivename=2020.07.1-current # patch releases don't follow the same format so we can't use $pkgver
source=(Waterfox-$_archivename.tar.gz::https://github.com/MrAlex94/Waterfox/archive/$_archivename.tar.gz
- $pkgname.desktop)
-sha256sums=('150f46733f1ae28d9ea0b0840069a4080e637a24c49863b81dade3f26ea514bd'
- '3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3')
+ $pkgname.desktop
+ bug1654465.diff)
+sha256sums=('71be464bd6c593245a237a43f2e125a4e7dd45f8f6c96528d478ce2af150bc42'
+ '3c8a3e73ffcb4670ca25fc7087b9c5d93ebbef2f3be8a33cf81ae424c3f27fa3'
+ '4d181c76060845048092724b2fc6f0c2aa76db543c9ba3490f313651de6bb97d')
prepare() {
mkdir -p mozbuild
cd Waterfox-$_archivename
+ # https://bugzilla.mozilla.org/show_bug.cgi?id=1654465
+ patch -Np1 -i ../bug1654465.diff
+
cat >../mozconfig <<END
ac_add_options --enable-application=browser
@@ -41,6 +46,7 @@ ac_add_options --enable-release
ac_add_options --enable-hardening
ac_add_options --enable-optimize
ac_add_options --enable-rust-simd
+ac_add_options --enable-linker=lld
export CC='clang --target=x86_64-unknown-linux-gnu'
export CXX='clang++ --target=x86_64-unknown-linux-gnu'
export AR=llvm-ar
diff --git a/bug1654465.diff b/bug1654465.diff
new file mode 100644
index 000000000000..7b6e4311556f
--- /dev/null
+++ b/bug1654465.diff
@@ -0,0 +1,78 @@
+ build/moz.configure/rust.configure | 2 +-
+ config/makefiles/rust.mk | 5 +++++
+ .../mozbuild/test/configure/test_toolchain_configure.py | 14 --------------
+ 3 files changed, 6 insertions(+), 15 deletions(-)
+
+diff --git c/build/moz.configure/rust.configure i/build/moz.configure/rust.configure
+index aaa693059d95..c90ae5ca7b25 100644
+--- c/build/moz.configure/rust.configure
++++ i/build/moz.configure/rust.configure
+@@ -146,8 +146,8 @@ def rust_compiler(rustc_info, cargo_info, build_project):
+ or by directly running the installer from https://rustup.rs/
+ '''))
+ if build_project == 'tools/crashreporter':
+- rustc_min_version = Version('1.22.0')
++ rustc_min_version = Version('1.38.0')
+ cargo_min_version = Version('0.23.0')
+ else:
+ rustc_min_version = Version('1.43.0')
+ cargo_min_version = rustc_min_version
+diff --git c/config/makefiles/rust.mk i/config/makefiles/rust.mk
+index a9abcc9af4c0..b5c7973104ce 100644
+--- c/config/makefiles/rust.mk
++++ i/config/makefiles/rust.mk
+@@ -63,6 +63,11 @@ ifndef MOZ_DEBUG_RUST
+ ifeq (,$(findstring gkrust_gtest,$(RUST_LIBRARY_FILE)))
+ cargo_rustc_flags += -Clto
+ endif
++# Versions of rust >= 1.45 need -Cembed-bitcode=yes for all crates when
++# using -Clto.
++ifeq (,$(filter 1.38.% 1.39.% 1.40.% 1.41.% 1.42.% 1.43.% 1.44.%,$(RUSTC_VERSION)))
++RUSTFLAGS += -Cembed-bitcode=yes
++endif
+ endif
+ endif
+
+diff --git c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
+index e1921ece6865..759d4d98cc0d 100755
+--- c/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
++++ i/python/mozbuild/mozbuild/test/configure/test_toolchain_configure.py
+@@ -1796,38 +1796,24 @@ class RustTest(BaseConfigureTest):
+ arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
+ 'thumbv7neon-linux-androideabi')
+
+- self.assertEqual(
+- self.get_rust_target('arm-unknown-linux-androideabi',
+- version='1.32.0',
+- arm_target=ReadOnlyNamespace(
+- arm_arch=7, fpu='neon', thumb2=True, float_abi='softfp')),
+- 'armv7-linux-androideabi')
+-
+ self.assertEqual(
+ self.get_rust_target('arm-unknown-linux-androideabi',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='neon', thumb2=False, float_abi='softfp')),
+ 'armv7-linux-androideabi')
+
+ self.assertEqual(
+ self.get_rust_target('arm-unknown-linux-androideabi',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='vfpv2', thumb2=True, float_abi='softfp')),
+ 'armv7-linux-androideabi')
+
+ self.assertEqual(
+ self.get_rust_target('armv7-unknown-linux-gnueabihf',
+ arm_target=ReadOnlyNamespace(
+ arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
+ 'thumbv7neon-unknown-linux-gnueabihf')
+
+- self.assertEqual(
+- self.get_rust_target('armv7-unknown-linux-gnueabihf',
+- version='1.32.0',
+- arm_target=ReadOnlyNamespace(
+- arm_arch=7, fpu='neon', thumb2=True, float_abi='hard')),
+- 'armv7-unknown-linux-gnueabihf')
+-
+ self.assertEqual(
+ self.get_rust_target('armv7-unknown-linux-gnueabihf',
+ arm_target=ReadOnlyNamespace(