summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMatt Parnell2019-06-07 23:32:15 -0500
committerMatt Parnell2019-06-07 23:32:15 -0500
commit78492b4cc8172dc37337c176176edd7b293e2e65 (patch)
treefeefe8a96d759affea07859ce559720375553a30
parent6e7795c1f0ad2c4f1f29b08be60590061c8d02e0 (diff)
downloadaur-78492b4cc8172dc37337c176176edd7b293e2e65.tar.gz
update the build
-rw-r--r--.SRCINFO40
-rw-r--r--PKGBUILD41
-rw-r--r--disable-synth-dammit.patch192
-rw-r--r--mozconfig17
4 files changed, 49 insertions, 241 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 8a5cdd9aada9..f615e01f10a7 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -10,38 +10,42 @@ pkgbase = waterfox-alpha-git
makedepends = unzip
makedepends = zip
makedepends = diffutils
- makedepends = python2
+ makedepends = python2-setuptools
makedepends = yasm
makedepends = mesa
makedepends = imake
- makedepends = gconf
- makedepends = xorg-server-xvfb
- makedepends = libpulse
makedepends = inetutils
+ makedepends = xorg-server-xvfb
makedepends = autoconf2.13
+ makedepends = rust
+ makedepends = mercurial
makedepends = clang
makedepends = llvm
- makedepends = cargo
- depends = gtk2
+ makedepends = jack
+ makedepends = gtk2
+ makedepends = python
+ makedepends = nodejs
+ makedepends = python2-psutil
+ makedepends = cbindgen
+ makedepends = nasm
+ depends = gtk3
depends = libffi
depends = libvpx
- depends = gtk3
+ depends = icu
+ depends = libevent
depends = mozilla-common
depends = libxt
depends = startup-notification
+ depends = mime-types
depends = dbus-glib
- depends = alsa-lib
depends = ffmpeg
- depends = desktop-file-utils
- depends = hicolor-icon-theme
- depends = libvpx
- depends = icu
- depends = libevent
depends = nss
- depends = hunspell
- depends = sqlite
depends = ttf-font
- depends = cbindgen
+ depends = libpulse
+ optdepends = libnotify: Notification integration
+ optdepends = pulseaudio: Audio support
+ optdepends = speech-dispatcher: Text-to-Speech
+ optdepends = hunspell-en_US: Spell checking, American English
conflicts = waterfox-alpha-bin
options = !emptydirs
options = !makeflags
@@ -50,13 +54,11 @@ pkgbase = waterfox-alpha-git
source = mozconfig
source = waterfox-alpha.desktop
source = ignore_bad_validator.patch
- source = disable-synth-dammit.patch
source = vendor.js
sha512sums = SKIP
- sha512sums = 2462c2ca8451d542b1ca7d344c34500372e95fea7d882b47cd64d2315aefce773af4803a475b9678a71bc0a647d12785e1892505798a1c5709d215690af85518
+ sha512sums = b63bfbce4cceef1751f9332d3e9583aa58c1df5b3cd09ce7be9803cdbaf321fdd98c8aa81b5a4b4e9c61814748a2b8a977c241427e1d7d07a0774d32bef59f2d
sha512sums = a133c3667bc11b3d19b6a1c9379f0112eca6a59df4096f476e480782de7fd395784de935c6c19b16051a4d5507b0c7f020cb35728f5a4dceb60474a931525673
sha512sums = ab2aced2e371afad317ab3ffb3e8161c457f022327e182d426aa2ba4142112060225ced4610eb2525e1c739a4e56ad4e7cf78cc102232cf01cf06d0224a9c09d
- sha512sums = d58c856c1614dfd674a3c4c79f6dd237c0417dbf37c89a269a8744bad46bff4c707a5e319872762f8bd05c2dd532ffa225490dfafaab784c70131c72614b0d4e
sha512sums = d927e5e882115c780aa0d45034cb1652eaa191d95c15013639f9172ae734245caae070018465d73fdf86a01601d08c9e65f28468621422d799fe8451e6175cb7
pkgname = waterfox-alpha-git
diff --git a/PKGBUILD b/PKGBUILD
index c74fbf5b66cf..b1d15046318a 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -6,11 +6,16 @@ pkgdesc="More private and optimized Firefox fork. Alpha (gecko68) branch. CREATE
arch=('i686' 'x86_64')
license=('MPL')
url="https://www.waterfoxproject.org/"
-depends=('gtk2' 'libffi' 'libvpx' 'gtk3' 'mozilla-common' 'libxt' 'startup-notification'
- 'dbus-glib' 'alsa-lib' 'ffmpeg' 'desktop-file-utils' 'hicolor-icon-theme'
- 'libvpx' 'icu' 'libevent' 'nss' 'hunspell' 'sqlite' 'ttf-font' 'cbindgen')
-makedepends=('unzip' 'zip' 'diffutils' 'python2' 'yasm' 'mesa' 'imake' 'gconf'
- 'xorg-server-xvfb' 'libpulse' 'inetutils' 'autoconf2.13' 'clang' 'llvm' 'cargo')
+depends=(gtk3 libffi libvpx icu libevent mozilla-common libxt startup-notification mime-types dbus-glib
+ ffmpeg nss ttf-font libpulse)
+makedepends=(unzip zip diffutils python2-setuptools yasm mesa imake inetutils
+ xorg-server-xvfb autoconf2.13 rust mercurial clang llvm jack gtk2
+ python nodejs python2-psutil cbindgen nasm)
+optdepends=('libnotify: Notification integration'
+ 'pulseaudio: Audio support'
+ 'speech-dispatcher: Text-to-Speech'
+ 'hunspell-en_US: Spell checking, American English')
+options=(!emptydirs !makeflags)
provides=()
conflicts=('waterfox-alpha-bin')
install=waterfox-alpha.install
@@ -19,15 +24,13 @@ source=(git://github.com/MrAlex94/Waterfox#branch=gecko68
mozconfig
waterfox-alpha.desktop
ignore_bad_validator.patch
- disable-synth-dammit.patch
vendor.js)
sha512sums=('SKIP'
- '2462c2ca8451d542b1ca7d344c34500372e95fea7d882b47cd64d2315aefce773af4803a475b9678a71bc0a647d12785e1892505798a1c5709d215690af85518'
+ 'b63bfbce4cceef1751f9332d3e9583aa58c1df5b3cd09ce7be9803cdbaf321fdd98c8aa81b5a4b4e9c61814748a2b8a977c241427e1d7d07a0774d32bef59f2d'
'a133c3667bc11b3d19b6a1c9379f0112eca6a59df4096f476e480782de7fd395784de935c6c19b16051a4d5507b0c7f020cb35728f5a4dceb60474a931525673'
'ab2aced2e371afad317ab3ffb3e8161c457f022327e182d426aa2ba4142112060225ced4610eb2525e1c739a4e56ad4e7cf78cc102232cf01cf06d0224a9c09d'
- 'd58c856c1614dfd674a3c4c79f6dd237c0417dbf37c89a269a8744bad46bff4c707a5e319872762f8bd05c2dd532ffa225490dfafaab784c70131c72614b0d4e'
'd927e5e882115c780aa0d45034cb1652eaa191d95c15013639f9172ae734245caae070018465d73fdf86a01601d08c9e65f28468621422d799fe8451e6175cb7')
-
+
# don't compress the package - we're just going to uncompress during install in a moment
PKGEXT='.pkg.tar'
@@ -47,19 +50,6 @@ prepare() {
# the below is a really horrible thing to do but it allows commas in our optimizations to work
patch -Np1 -i "${srcdir}/ignore_bad_validator.patch"
- # and this is a hacky workaround so we can build without html5 and
- # speex support - also in .mozconfig if you want to build with it, comment both out
- warning "Applying patch to facilitate build without speex and html5 voice synth."
- warning "To build with it, please edit the .mozconfig and adjust the options to enable what you need: "
- warning " ac_add_options --disable-accessibility"
- warning " ac_add_options --disable-synth-speechd"
- warning " ac_add_options --disable-webspeech=1"
- warning "Then, comment out the disable-synth-dammit.patch line in the PKGBUILD."
- warning "Press ENTER if you want to build now or CTRL+C to abort..."
- read
-
- patch -Np1 -i "${srcdir}/disable-synth-dammit.patch"
-
mkdir -p "$srcdir/path"
}
@@ -68,8 +58,13 @@ build() {
export PATH="$srcdir/path:$PATH"
export PYTHON="/usr/bin/python2"
+ export MOZ_NOSPAM=1
+ export MOZBUILD_STATE_PATH="$srcdir/mozbuild"
+
+ # LTO needs more open files
+ ulimit -n 4096
- ./mach build
+ xvfb-run -a -n 97 -s "-screen 0 1600x1200x24" ./mach build
}
package() {
diff --git a/disable-synth-dammit.patch b/disable-synth-dammit.patch
deleted file mode 100644
index e35a214241a8..000000000000
--- a/disable-synth-dammit.patch
+++ /dev/null
@@ -1,192 +0,0 @@
-diff --git a/dom/ipc/ContentChild.cpp b/dom/ipc/ContentChild.cpp
-index 9b5ce2d42697..d6c9f3a3a333 100644
---- a/dom/ipc/ContentChild.cpp
-+++ b/dom/ipc/ContentChild.cpp
-@@ -2131,22 +2131,16 @@ bool ContentChild::DeallocPMediaChild(media::PMediaChild* aActor) {
- return media::DeallocPMediaChild(aActor);
- }
-
--PSpeechSynthesisChild* ContentChild::AllocPSpeechSynthesisChild() {
- #ifdef MOZ_WEBSPEECH
-+PSpeechSynthesisChild* ContentChild::AllocPSpeechSynthesisChild() {
- MOZ_CRASH("No one should be allocating PSpeechSynthesisChild actors");
--#else
-- return nullptr;
--#endif
- }
-
- bool ContentChild::DeallocPSpeechSynthesisChild(PSpeechSynthesisChild* aActor) {
--#ifdef MOZ_WEBSPEECH
- delete aActor;
- return true;
--#else
-- return false;
--#endif
- }
-+#endif
-
- PWebrtcGlobalChild* ContentChild::AllocPWebrtcGlobalChild() {
- #ifdef MOZ_WEBRTC
-diff --git a/dom/ipc/ContentChild.h b/dom/ipc/ContentChild.h
-index f1f90e4aed06..eea1a906155b 100644
---- a/dom/ipc/ContentChild.h
-+++ b/dom/ipc/ContentChild.h
-@@ -301,9 +301,11 @@ class ContentChild final : public PContentChild,
-
- mozilla::ipc::IPCResult RecvNotifyEmptyHTTPCache();
-
-+#ifdef MOZ_WEBSPEECH
- PSpeechSynthesisChild* AllocPSpeechSynthesisChild();
-
- bool DeallocPSpeechSynthesisChild(PSpeechSynthesisChild* aActor);
-+#endif
-
- mozilla::ipc::IPCResult RecvRegisterChrome(
- InfallibleTArray<ChromePackage>&& packages,
-diff --git a/dom/ipc/ContentParent.cpp b/dom/ipc/ContentParent.cpp
-index eb67685972b2..866245ebe432 100644
---- a/dom/ipc/ContentParent.cpp
-+++ b/dom/ipc/ContentParent.cpp
-@@ -3699,35 +3699,25 @@ mozilla::ipc::IPCResult ContentParent::RecvPPresentationConstructor(
- return IPC_OK();
- }
-
--PSpeechSynthesisParent* ContentParent::AllocPSpeechSynthesisParent() {
- #ifdef MOZ_WEBSPEECH
-+PSpeechSynthesisParent* ContentParent::AllocPSpeechSynthesisParent() {
- return new mozilla::dom::SpeechSynthesisParent();
--#else
-- return nullptr;
--#endif
- }
-
- bool ContentParent::DeallocPSpeechSynthesisParent(
- PSpeechSynthesisParent* aActor) {
--#ifdef MOZ_WEBSPEECH
- delete aActor;
- return true;
--#else
-- return false;
--#endif
- }
-
- mozilla::ipc::IPCResult ContentParent::RecvPSpeechSynthesisConstructor(
- PSpeechSynthesisParent* aActor) {
--#ifdef MOZ_WEBSPEECH
- if (!static_cast<SpeechSynthesisParent*>(aActor)->SendInit()) {
- return IPC_FAIL_NO_REASON(this);
- }
- return IPC_OK();
--#else
-- return IPC_FAIL_NO_REASON(this);
--#endif
- }
-+#endif
-
- mozilla::ipc::IPCResult ContentParent::RecvStartVisitedQuery(
- const URIParams& aURI) {
-diff --git a/dom/ipc/ContentParent.h b/dom/ipc/ContentParent.h
-index 416ae2f7bf4d..34ce13d1a4f5 100644
---- a/dom/ipc/ContentParent.h
-+++ b/dom/ipc/ContentParent.h
-@@ -918,12 +918,14 @@ class ContentParent final : public PContentParent,
- virtual mozilla::ipc::IPCResult RecvPPresentationConstructor(
- PPresentationParent* aActor) override;
-
-+#ifdef MOZ_WEBSPEECH
- PSpeechSynthesisParent* AllocPSpeechSynthesisParent();
-
- bool DeallocPSpeechSynthesisParent(PSpeechSynthesisParent* aActor);
-
- virtual mozilla::ipc::IPCResult RecvPSpeechSynthesisConstructor(
- PSpeechSynthesisParent* aActor) override;
-+#endif
-
- PWebBrowserPersistDocumentParent* AllocPWebBrowserPersistDocumentParent(
- PBrowserParent* aBrowser, const uint64_t& aOuterWindowID);
-diff --git a/dom/ipc/PContent.ipdl b/dom/ipc/PContent.ipdl
-index 141c75af96e7..708360237696 100644
---- a/dom/ipc/PContent.ipdl
-+++ b/dom/ipc/PContent.ipdl
-@@ -31,7 +31,7 @@ include protocol PPrinting;
- include protocol PChildToParentStream;
- include protocol PParentToChildStream;
- include protocol POfflineCacheUpdate;
--include protocol PSpeechSynthesis;
-+/*include protocol PSpeechSynthesis;*/
- include protocol PTestShell;
- include protocol PJavaScript;
- include protocol PRemoteSpellcheckEngine;
-@@ -343,7 +343,7 @@ nested(upto inside_cpow) sync protocol PContent
- manages PPrinting;
- manages PChildToParentStream;
- manages PParentToChildStream;
-- manages PSpeechSynthesis;
-+/* manages PSpeechSynthesis;*/
- manages PTestShell;
- manages PJavaScript;
- manages PRemoteSpellcheckEngine;
-@@ -860,7 +860,7 @@ parent:
-
- async PChildToParentStream();
-
-- async PSpeechSynthesis();
-+ /*async PSpeechSynthesis();*/
-
- async PMedia();
-
-diff --git a/dom/ipc/moz.build b/dom/ipc/moz.build
-index fe4cfe7a7426..62daca2a85ae 100644
---- a/dom/ipc/moz.build
-+++ b/dom/ipc/moz.build
-@@ -151,6 +151,11 @@ if CONFIG['MOZ_SANDBOX'] and (CONFIG['OS_TARGET'] in ['Darwin', 'Linux']):
- 'mozsandbox',
- ]
-
-+if CONFIG['MOZ_WEBSPEECH']:
-+ LOCAL_INCLUDES += [
-+ '/dom/media/webspeech/synth/ipc'
-+ ]
-+
- LOCAL_INCLUDES += [
- '/caps',
- '/chrome',
-@@ -160,7 +165,6 @@ LOCAL_INCLUDES += [
- '/dom/events',
- '/dom/filesystem',
- '/dom/geolocation',
-- '/dom/media/webspeech/synth/ipc',
- '/dom/security',
- '/dom/storage',
- '/extensions/permissions',
-diff --git a/dom/media/webspeech/moz.build b/dom/media/webspeech/moz.build
-index 85e2277b388b..1eb7dd199287 100644
---- a/dom/media/webspeech/moz.build
-+++ b/dom/media/webspeech/moz.build
-@@ -3,7 +3,8 @@
- # License, v. 2.0. If a copy of the MPL was not distributed with this
- # file, You can obtain one at http://mozilla.org/MPL/2.0/.
-
--DIRS = ['synth']
-+if CONFIG['MOZ_SYNTH_SPEECHD']:
-+ DIRS = ['synth']
-
--if CONFIG['MOZ_WEBSPEECH']:
-- DIRS += ['recognition']
-+ if CONFIG['MOZ_WEBSPEECH']:
-+ DIRS += ['recognition']
-diff --git a/ipc/ipdl/ipdl/direct_call.py b/ipc/ipdl/ipdl/direct_call.py
-index 77f75f8b2813..97fcea5320e3 100644
---- a/ipc/ipdl/ipdl/direct_call.py
-+++ b/ipc/ipdl/ipdl/direct_call.py
-@@ -553,8 +553,8 @@ VIRTUAL_CALL_CLASSES = set([
- ("PPluginWidget", "parent"),
- ("PProfiler", "child"),
- ("PProfiler", "parent"),
-- ("PSpeechSynthesisRequest", "child"),
-- ("PSpeechSynthesisRequest", "parent"),
-+ #("PSpeechSynthesisRequest", "child"),
-+ #("PSpeechSynthesisRequest", "parent"),
- ("PStunAddrsRequest", "child"),
- ("PStunAddrsRequest", "parent"),
- ("PWebrtcProxyChannel", "child"),
diff --git a/mozconfig b/mozconfig
index 4cad520f27d2..6ef23e7b58e0 100644
--- a/mozconfig
+++ b/mozconfig
@@ -4,6 +4,7 @@ export CXX=clang++
export AR=llvm-ar
export NM=llvm-nm
export RANLIB=llvm-ranlib
+export MOZ_PGO=1
mk_add_options AUTOCLOBBER=1
export CPPFLAGS=""
@@ -29,6 +30,9 @@ X=$(($(getconf _NPROCESSORS_ONLN 2>/dev/null || getconf NPROCESSORS_ONLN)*3/2))
mk_add_options MOZ_MAKE_FLAGS=-j${X%.*}
fi
+ac_add_options "MOZ_ALLOW_LEGACY_EXTENSIONS=1"
+
+ac_add_options MOZ_PGO=1
ac_add_options --enable-strip
ac_add_options --enable-hardening
@@ -38,15 +42,15 @@ ac_add_options --libdir=/opt
ac_add_options --enable-rust-simd # on x86 requires SSE2
ac_add_options --enable-gold
-ac_add_options --disable-jemalloc
-ac_add_options --enable-lto=thin # full lto is slower, while thin still probably nets all the usual benefits
+#ac_add_options --disable-jemalloc
+ac_add_options --enable-lto
ac_add_options --enable-release
ac_add_options --enable-application=browser
ac_add_options --enable-eme=widevine
ac_add_options --enable-update-channel=aurora
-ac_add_options --with-app-name=waterfox
-ac_add_options --with-app-basename=Waterfox
+ac_add_options --with-app-name=waterfox-alpha
+ac_add_options --with-app-basename=Waterfox-Alpha
ac_add_options --with-branding=browser/branding/alpha
ac_add_options --with-distribution-id=net.waterfox
@@ -75,8 +79,8 @@ ac_add_options --enable-default-toolkit=cairo-gtk3
# Features
ac_add_options --disable-accessibility
-ac_add_options --disable-synth-speechd
-ac_add_options --disable-webspeech=1
+#ac_add_options --disable-synth-speechd
+#ac_add_options --disable-webspeech=1
ac_add_options --disable-gpsd
ac_add_options --disable-debug
ac_add_options --disable-dmd
@@ -86,7 +90,6 @@ ac_add_options --disable-eme
ac_add_options --disable-js-shell
ac_add_options --disable-updater
ac_add_options --disable-verify-mar
-ac_add_options --disable-webspeech
ac_add_options --disable-necko-wifi
ac_add_options --disable-webrtc
ac_add_options --disable-tests