summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhawkeye1164772020-02-26 09:00:50 +0100
committerhawkeye1164772020-02-26 09:00:50 +0100
commit8f9ad66893ccb99ed43913d68c391d63c3ad96b6 (patch)
tree0abcdc66a0b00f6cc9d7d73d99fc43cc62689d31
parent65df35b70c3445cfb0ec54e4fbc96b87f0f0cd51 (diff)
downloadaur-8f9ad66893ccb99ed43913d68c391d63c3ad96b6.tar.gz
Fix icons
-rw-r--r--.SRCINFO5
-rw-r--r--PKGBUILD19
-rw-r--r--waterfox-classic.desktop1
3 files changed, 14 insertions, 11 deletions
diff --git a/.SRCINFO b/.SRCINFO
index 6034db39fa49..d0896c068d80 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -1,7 +1,7 @@
pkgbase = waterfox-classic-bin
pkgdesc = Customizable privacy conscious web browser with primary support for legacy extensions
pkgver = 2020.02.1
- pkgrel = 1
+ pkgrel = 2
url = https://www.waterfox.net
arch = x86_64
license = MPL
@@ -22,10 +22,11 @@ pkgbase = waterfox-classic-bin
optdepends = speech-dispatcher: Text-to-Speech
provides = waterfox-classic=2020.02.1
conflicts = waterfox-classic
+ conflicts = waterfox-classic-git
replaces = waterfox-bin
source = waterfox-classic.desktop
source = https://storage-waterfox.netdna-ssl.com/releases/linux64/installer/waterfox-classic-2020.02.1.en-US.linux-x86_64.tar.bz2
- sha256sums = a364e830e980417095a5a45fb2c9c635fa8d248884816c26e3f31ce993130537
+ sha256sums = 67bcd2aed38969553130872652946ddd00a804ba2046c14a554e9bb99de54b24
sha256sums = fdb29a5504f378165a8c126772f419472ff3e4e058abe901f29068ff12ff521e
pkgname = waterfox-classic-bin
diff --git a/PKGBUILD b/PKGBUILD
index 890a63f3ea02..a3c2a56bb789 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -4,7 +4,7 @@
pkgname=waterfox-classic-bin
pkgver=2020.02.1
-pkgrel=1
+pkgrel=2
pkgdesc="Customizable privacy conscious web browser with primary support for legacy extensions"
arch=('x86_64')
url="https://www.waterfox.net"
@@ -17,7 +17,7 @@ optdepends=('networkmanager: Location detection via available WiFi networks'
'alsa-lib: Audio support'
'speech-dispatcher: Text-to-Speech')
provides=("waterfox-classic=${pkgver}")
-conflicts=('waterfox-classic')
+conflicts=('waterfox-classic' 'waterfox-classic-git')
replaces=('waterfox-bin')
source=(
@@ -29,18 +29,19 @@ package() {
# Create the directories.
install -d "${pkgdir}"/{usr/{bin,share/applications},opt}
- # Install the desktop and the icon files.
+ # Install the desktop files.
install -m644 "${srcdir}"/waterfox-classic.desktop "${pkgdir}"/usr/share/applications/
+ # Copy the directory to /opt
+ cp -r waterfox-classic "${pkgdir}"/opt/waterfox-classic
+
+ # Install icons
for i in 16 22 24 32 48 64 128 256; do
install -d "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps"
- ln -Tsf "${srcdir}"/waterfox-classic/browser/chrome/icons/default/default$i.png \
+ ln -Ts /opt/waterfox-classic/browser/chrome/icons/default/default$i.png \
"$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/waterfox-classic.png"
done
- # Copy the directory to /opt
- cp -r waterfox-classic "${pkgdir}"/opt/waterfox-classic
-
# Install a wrapper to avoid confusion about binary path
install -Dm755 /dev/stdin "$pkgdir/usr/bin/waterfox-classic" <<END
#!/bin/sh
@@ -58,5 +59,5 @@ END
ln -Ts /usr/share/hyphen "$pkgdir/opt/waterfox-classic/hyphenation"
}
-sha256sums=('a364e830e980417095a5a45fb2c9c635fa8d248884816c26e3f31ce993130537'
- 'fdb29a5504f378165a8c126772f419472ff3e4e058abe901f29068ff12ff521e')
+sha256sums=('67bcd2aed38969553130872652946ddd00a804ba2046c14a554e9bb99de54b24'
+ 'fdb29a5504f378165a8c126772f419472ff3e4e058abe901f29068ff12ff521e')
diff --git a/waterfox-classic.desktop b/waterfox-classic.desktop
index 22a9bd0c1cc1..6dab26f52d6a 100644
--- a/waterfox-classic.desktop
+++ b/waterfox-classic.desktop
@@ -119,6 +119,7 @@ Type=Application
Icon=waterfox-classic
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/xml;application/rss+xml;application/rdf+xml;image/gif;image/jpeg;image/png;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;x-scheme-handler/chrome;video/webm;application/x-xpinstall;application/vnd.mozilla.xul+xml;text/mml
+StartupWMClass=Waterfox
StartupNotify=true
Actions=NewTab;NewWindow;NewPrivateWindow;