summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorhawkeye1164772020-03-12 11:19:12 +0100
committerhawkeye1164772020-03-12 11:19:12 +0100
commit0773202a12736b317e99aba5fe3107440b88fc23 (patch)
tree24e39a6ee406aacfbabb0cd7e51ee21a7f40c8f1
parentb3ce32024096ffc9e2275911ba183d5fe6b192bd (diff)
downloadaur-0773202a12736b317e99aba5fe3107440b88fc23.tar.gz
Small improvements
/usr/share/pixmaps deprecated; added few useful settings
-rw-r--r--.SRCINFO2
-rw-r--r--PKGBUILD33
-rw-r--r--waterfox-current.desktop2
3 files changed, 29 insertions, 8 deletions
diff --git a/.SRCINFO b/.SRCINFO
index b55c3207280f..5ff2aa9663a4 100644
--- a/.SRCINFO
+++ b/.SRCINFO
@@ -26,7 +26,7 @@ pkgbase = waterfox-current-bin
replaces = waterfox-alpha-bin
source = waterfox-current.desktop
source = https://storage-waterfox.netdna-ssl.com/releases/linux64/installer/waterfox-current-2020.03.en-US.linux-x86_64.tar.bz2
- sha256sums = 4935fc30e327cbb665b6a98ed21a3f0d27b5a1407bbb9988bb7b607a85e0065d
+ sha256sums = b8db6f9ee6abd9349b41333bf01ba04ef78a36335f94f35d9ea6762bc4fea548
sha256sums = 0aa372a14790cf79840d31864a49e01ae07396b7b28b103844780865e5b2feb5
pkgname = waterfox-current-bin
diff --git a/PKGBUILD b/PKGBUILD
index d762e2e8a157..96fdf705b4e5 100644
--- a/PKGBUILD
+++ b/PKGBUILD
@@ -1,5 +1,5 @@
# Maintainer: Simon Kronberg <Simon.Kronberg@gmail.com>
-# Contributor: hawkeye116477 <hawkeye116477@gmail.com>
+# Contributor: hawkeye116477 <hawkeye116477 at gmail dot com>
pkgname=waterfox-current-bin
pkgver=2020.03
@@ -25,18 +25,39 @@ source=('waterfox-current.desktop'
package() {
# Create the necessary directories.
- install -d "${pkgdir}"/{usr/{bin,share/{applications,pixmaps}},opt}
+ install -d "${pkgdir}"/{usr/{bin,share/applications},opt}
- # Move the .desktop file and the icon.
+ # Install the desktop files.
install -m644 "${srcdir}"/waterfox-current.desktop "${pkgdir}"/usr/share/applications/
- install -m644 "${srcdir}"/waterfox/browser/chrome/icons/default/default128.png "${pkgdir}"/usr/share/pixmaps/waterfox-current-icon.png
# Copy the extracted directory to /opt/.
cp -r waterfox "${pkgdir}"/opt/waterfox-current
+ # Install icons
+ for i in 16 32 48 64 128; do
+ install -d "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps"
+ ln -Ts /opt/waterfox-current/browser/chrome/icons/default/default$i.png \
+ "$pkgdir/usr/share/icons/hicolor/${i}x${i}/apps/waterfox-current.png"
+ done
+
+ # Add additional useful settings
+ install -Dm644 /dev/stdin "$pkgdir/opt/waterfox-current/browser/defaults/preferences/vendor.js" <<END
+// Disable default browser checking
+pref("browser.shell.checkDefaultBrowser", false);
+
+// Use LANG environment variable to choose locale
+pref("intl.locale.requested", "");
+
+// Automatic installation of updates won't work on root, so disable this
+pref("app.update.auto", false);
+
+// Use system-provided dictionaries
+pref("spellchecker.dictionary_path", "/usr/share/hunspell");
+END
+
# Symlink the binary to /usr/bin/.
ln -s /opt/waterfox-current/waterfox "${pkgdir}"/usr/bin/waterfox-current
}
-sha256sums=('4935fc30e327cbb665b6a98ed21a3f0d27b5a1407bbb9988bb7b607a85e0065d'
- '0aa372a14790cf79840d31864a49e01ae07396b7b28b103844780865e5b2feb5') #
+sha256sums=('b8db6f9ee6abd9349b41333bf01ba04ef78a36335f94f35d9ea6762bc4fea548'
+ '0aa372a14790cf79840d31864a49e01ae07396b7b28b103844780865e5b2feb5')
diff --git a/waterfox-current.desktop b/waterfox-current.desktop
index d54938321a7d..5a0c4e4c919e 100644
--- a/waterfox-current.desktop
+++ b/waterfox-current.desktop
@@ -84,7 +84,7 @@ Comment[zh_TW]=瀏覽網際網路
Exec=waterfox-current %u
Terminal=false
Type=Application
-Icon=waterfox-current-icon
+Icon=waterfox-current
Categories=Network;WebBrowser;
MimeType=text/html;text/xml;application/xhtml+xml;application/vnd.mozilla.xul+xml;text/mml;x-scheme-handler/http;x-scheme-handler/https;x-scheme-handler/ftp;
StartupNotify=true