summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAmolith2024-02-21 15:12:25 -0500
committerAmolith2024-02-21 15:12:25 -0500
commitccbe7a52734af74cb4fcc783599b014e3f5f06d7 (patch)
tree48223ee9c9013b7be57a12cc360d7e581849f220
downloadaur-ccbe7a52734af74cb4fcc783599b014e3f5f06d7.tar.gz
Initial commit at v0.0.4
-rw-r--r--.SRCINFO13
-rw-r--r--PKGBUILD20
2 files changed, 33 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..60271185e607
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,13 @@
+pkgbase = watt-wiser-bin
+ pkgdesc = A software energy consumption estimation tool
+ pkgver = v0.0.4
+ pkgrel = 1
+ url = https://github.com/wattwisegames/watt-wiser
+ arch = any
+ license = Unlicense
+ provides = watt-wiser
+ conflicts = watt-wiser
+ source = watt-wiser-v0.0.4-linux.tar.xz::https://github.com/wattwisegames/watt-wiser/releases/download/v0.0.4/watt-wiser-v0.0.4-linux.tar.xz
+ sha256sums = 7c8bf25b0ba4f166387a922ffbd860404e65d312a14c8efa7bd64f991ff7e146
+
+pkgname = watt-wiser-bin
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..9273e5cbc474
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: Amolith <amolith@secluded.site>
+pkgname="watt-wiser-bin"
+_pkgname=${pkgname%-bin}
+pkgdesc="A software energy consumption estimation tool"
+_repo="watt-wiser"
+pkgver="v0.0.4"
+pkgrel=1
+arch=("any")
+url="https://github.com/wattwisegames/$_repo"
+source=("${_repo}-${pkgver}-linux.tar.xz"::"${url}/releases/download/${pkgver}/${_repo}-${pkgver}-linux.tar.xz")
+license=("Unlicense")
+provides=($_pkgname)
+conflicts=($_pkgname)
+
+sha256sums=('7c8bf25b0ba4f166387a922ffbd860404e65d312a14c8efa7bd64f991ff7e146')
+
+package() {
+ cd "${_repo}-${pkgver}-linux"
+ install -Dm755 "$_pkgname" "$pkgdir/usr/bin/$_pkgname"
+}