summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorAlif Rachmawadi2017-04-11 08:25:39 +0700
committerAlif Rachmawadi2017-04-11 08:25:39 +0700
commit24d11c1da3c087feed337ae84500dcdb91800691 (patch)
treec53264be04bd93b8683853beaac3cccae257c1a8
downloadaur-24d11c1da3c087feed337ae84500dcdb91800691.tar.gz
initial commit
-rw-r--r--.SRCINFO27
-rw-r--r--.gitignore4
-rw-r--r--PKGBUILD38
-rw-r--r--wavebox.desktop10
4 files changed, 79 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..466d7b44d847
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,27 @@
+pkgbase = wavebox-bin
+ pkgdesc = The next generation of web-desktop communication
+ pkgver = 3.1.3
+ pkgrel = 1
+ url = https://wavebox.io/
+ arch = x86_64
+ arch = i686
+ license = Mozilla Public License version 2.0
+ depends = gconf
+ depends = gtk2
+ depends = libxtst
+ depends = nss
+ depends = alsa-lib
+ depends = libxss
+ optdepends = gvfs
+ optdepends = libnotify
+ provides = wavebox
+ options = !strip
+ source = wavebox.desktop
+ sha512sums = a6a55a0b0597eea63e2869ab27e3ddab802b020c89059b0b32399b63e64f0271e4685e363448da71c6ba90c810b83542cd0c9f40e2ce49057a8e33c54b82663b
+ source_x86_64 = https://github.com/wavebox/waveboxapp/releases/download/v3.1.3/Wavebox_3_1_3_linux_x86_64.tar.gz
+ sha512sums_x86_64 = e115bfeebc0e10422c57194450e6ebfea6525a6818bef011647076453f422b9fa8d43920cef95dd11b04008c00bab6403e1bbe7338606b73277abce4fd6d0dc5
+ source_i686 = https://github.com/wavebox/waveboxapp/releases/download/v3.1.3/Wavebox_3_1_3_linux_ia32.tar.gz
+ sha512sums_i686 = 1a68c83b70b9db2b3cca4e41be22fd1eff216ee58df5b5493fc2017d7323d02a59c3cdb6379c95c93be80b3a0ad864d66af18cbb6e70846c416d25fb45fdbb32
+
+pkgname = wavebox-bin
+
diff --git a/.gitignore b/.gitignore
new file mode 100644
index 000000000000..a3eb2e2f0a3a
--- /dev/null
+++ b/.gitignore
@@ -0,0 +1,4 @@
+pkg
+src
+Wavebox_*.tar.gz
+wavebox-bin-*.pkg.tar.xz
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..8d9fb9229910
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,38 @@
+# Maintainer: Alif Rachmawadi <code@subosito.com>
+
+pkgname=wavebox-bin
+pkgver=3.1.3
+pkgrel=1
+pkgdesc="The next generation of web-desktop communication"
+arch=('x86_64' 'i686')
+url="https://wavebox.io/"
+_repourl="https://github.com/wavebox/waveboxapp"
+license=('Mozilla Public License version 2.0')
+options=(!strip)
+provides=('wavebox')
+depends=('gconf' 'gtk2' 'libxtst' 'nss' 'alsa-lib' 'libxss')
+optdepends=('gvfs' 'libnotify')
+
+source=('wavebox.desktop')
+source_x86_64=("${_repourl}/releases/download/v${pkgver}/Wavebox_${pkgver//./_}_linux_${CARCH}.tar.gz")
+source_i686=("${_repourl}/releases/download/v${pkgver}/Wavebox_${pkgver//./_}_linux_ia32.tar.gz")
+
+sha512sums=('a6a55a0b0597eea63e2869ab27e3ddab802b020c89059b0b32399b63e64f0271e4685e363448da71c6ba90c810b83542cd0c9f40e2ce49057a8e33c54b82663b')
+sha512sums_x86_64=('e115bfeebc0e10422c57194450e6ebfea6525a6818bef011647076453f422b9fa8d43920cef95dd11b04008c00bab6403e1bbe7338606b73277abce4fd6d0dc5')
+sha512sums_i686=('1a68c83b70b9db2b3cca4e41be22fd1eff216ee58df5b5493fc2017d7323d02a59c3cdb6379c95c93be80b3a0ad864d66af18cbb6e70846c416d25fb45fdbb32')
+
+package() {
+ if [ ${CARCH} == "x86_64" ]; then
+ cd ${srcdir}/Wavebox-linux-x64
+ else
+ cd ${srcdir}/Wavebox-linux-ia32
+ fi
+
+ mkdir -p "${pkgdir}/usr/bin"
+ mkdir -p "${pkgdir}/usr/share/wavebox"
+ mkdir -p "${pkgdir}/usr/share/applications"
+
+ cp -R ./* "${pkgdir}/usr/share/wavebox"
+ cp "${srcdir}/wavebox.desktop" "${pkgdir}/usr/share/applications/wavebox.desktop"
+ ln -s "/usr/share/wavebox/Wavebox" "${pkgdir}/usr/bin/wavebox"
+}
diff --git a/wavebox.desktop b/wavebox.desktop
new file mode 100644
index 000000000000..7213807600e6
--- /dev/null
+++ b/wavebox.desktop
@@ -0,0 +1,10 @@
+[Desktop Entry]
+Exec=wavebox --mailto=%u
+Name=Wavebox
+Comment=The next generation of web-desktop communication
+Icon=/usr/share/wavebox/icon.png
+MimeType=x-scheme-handler/mailto;
+StartupNotify=true
+Terminal=false
+Type=Application
+Categories=Application;Network;Email;