summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorMichał Sałaban2020-05-01 15:45:37 +0200
committerMichał Sałaban2020-05-01 15:45:37 +0200
commit18924412750d74b1d70689774bdabdf226b5ecf2 (patch)
tree412ecf13a88342105ccd3e33ec0115bc198f4d3d
downloadaur-18924412750d74b1d70689774bdabdf226b5ecf2.tar.gz
Initial release
-rw-r--r--.SRCINFO20
-rw-r--r--PKGBUILD36
-rw-r--r--waves.conf49
-rw-r--r--waves.sysusers1
-rw-r--r--waves.tmpfiles2
5 files changed, 108 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..aa8c4ec391e9
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,20 @@
+pkgbase = waves
+ pkgdesc = Reference Waves Blockchain Node (client) implementation in Scala
+ pkgver = 1.2.4
+ pkgrel = 1
+ url = https://wavesplatform.com/
+ arch = any
+ license = MIT
+ makedepends = sbt
+ makedepends = java-environment>=8
+ depends = java-runtime>=8
+ backup = etc/waves/waves.conf
+ source = https://github.com/wavesplatform/Waves/archive/v1.2.4.tar.gz
+ source = waves.sysusers
+ source = waves.tmpfiles
+ sha256sums = 169221245c91828552e53716a04b3434d32407a136fb493eea814e62c67721ee
+ sha256sums = df4670b201ee1369f18c9bbad3effee1c6e374ac53cc435b7c68ab077eaacf0f
+ sha256sums =
+
+pkgname = waves
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..47727b9ff279
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,36 @@
+# Maintainer: Michał Sałaban <michal@salaban.info>
+pkgname=waves
+pkgver=1.2.4
+pkgrel=1
+pkgdesc="Reference Waves Blockchain Node (client) implementation in Scala"
+arch=('any')
+url="https://wavesplatform.com/"
+license=('MIT')
+depends=('java-runtime>=8')
+makedepends=('sbt' 'java-environment>=8')
+backup=('etc/waves/waves.conf')
+source=(
+ "https://github.com/wavesplatform/Waves/archive/v${pkgver}.tar.gz"
+ "${pkgname}.sysusers"
+ "${pkgname}.tmpfiles")
+sha256sums=(
+ "169221245c91828552e53716a04b3434d32407a136fb493eea814e62c67721ee"
+ "df4670b201ee1369f18c9bbad3effee1c6e374ac53cc435b7c68ab077eaacf0f"
+ "")
+
+build() {
+ rm -rf Waves-${pkgver}/node/target/*
+ cd Waves-${pkgver}
+ sbt packageAll
+}
+
+package() {
+ dpkg-deb -x Waves-${pkgver}/node/target/${pkgname}_*_all.deb ${pkgdir}
+ mv ${pkgdir}/lib/systemd ${pkgdir}/etc/
+ rm -rf ${pkgdir}/lib
+ rm -rf ${pkgdir}/etc/init
+ rm -f ${pkgdir}/etc/waves
+ install -Dm0644 "${pkgname}.conf" "${pkgdir}/etc/waves/${pkgname}.conf"
+ install -Dm0644 "${pkgname}.sysusers" "${pkgdir}/usr/lib/sysusers.d/${pkgname}.conf"
+ install -Dm0644 "${pkgname}.tmpfiles" "${pkgdir}/usr/lib/tmpfiles.d/${pkgname}.conf"
+}
diff --git a/waves.conf b/waves.conf
new file mode 100644
index 000000000000..5e4f72d8f375
--- /dev/null
+++ b/waves.conf
@@ -0,0 +1,49 @@
+# Waves Node settings for MainNet
+waves {
+ blockchain.type = MAINNET
+
+ # P2P Network settings
+ network {
+ # Port number
+ port = 6868
+
+ # Node name to send during handshake. Comment this string out to set random node name.
+ # node-name = "My MAINNET node"
+
+ # String with IP address and port to send as external address during handshake. Could be set automatically if uPnP is enabled.
+ # declared-address = "1.2.3.4:6868"
+
+ known-peers = [
+ "13.228.86.201:6868"
+ "13.229.0.149:6868"
+ "18.195.170.147:6868"
+ "34.253.153.4:6868"
+ "35.156.19.4:6868"
+ "52.50.69.247:6868"
+ "52.52.46.76:6868"
+ "52.57.147.71:6868"
+ "52.214.55.18:6868"
+ "54.176.190.226:6868"
+ ]
+ }
+
+ # Wallet settings
+ wallet {
+ # Password to protect wallet file
+ # password =
+ # Wallet seed as BASE58 string
+ # seed =
+ }
+
+ # Node's REST API settings
+ rest-api {
+ # Disable node's REST API
+ enable = no
+
+ # For security reasons, bind to local interface only
+ bind-address = "127.0.0.1"
+
+ # Port to listen to REST API requests
+ port = 6869
+ }
+}
diff --git a/waves.sysusers b/waves.sysusers
new file mode 100644
index 000000000000..f3d95bf5a2fa
--- /dev/null
+++ b/waves.sysusers
@@ -0,0 +1 @@
+u waves - - /var/lib/waves
diff --git a/waves.tmpfiles b/waves.tmpfiles
new file mode 100644
index 000000000000..c204dbd11de5
--- /dev/null
+++ b/waves.tmpfiles
@@ -0,0 +1,2 @@
+d /var/lib/waves 0770 waves waves - -
+d /var/log/waves 0755 waves waves - -