summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorgoll2018-05-11 14:32:48 +0200
committergoll2018-05-11 14:32:48 +0200
commit466e1cf699d947904c5450e312c0e5d835337b4a (patch)
treedc9ca564f2eb3953601a6282e65c2153f3648c93
downloadaur-466e1cf699d947904c5450e312c0e5d835337b4a.tar.gz
Initial waves-client commit
-rw-r--r--.SRCINFO18
-rw-r--r--PKGBUILD20
2 files changed, 38 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..f14f17ab1b0d
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,18 @@
+pkgbase = waves-client
+ pkgdesc = The official client application for the Waves platform
+ pkgver = 1.0.0_beta
+ pkgrel = 1
+ url = https://wavesplatform.com/
+ arch = x86_64
+ license = custom
+ depends = gtk2
+ depends = libxtst
+ depends = libxss
+ depends = gconf
+ depends = nss
+ depends = alsa-lib
+ source = https://wavesplatform.com/files/WavesClient-1.0.0-beta.X-linux.deb
+ sha256sums = 625dec99daa10b5455c2ff25451bcb83a60cef00f8e5af7f36b422e15117d04c
+
+pkgname = waves-client
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..ad6729d0a1b8
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,20 @@
+# Maintainer: goll <adrian.goll+aur[at]gmail>
+
+pkgname=waves-client
+pkgver=1.0.0_beta
+pkgrel=1
+pkgdesc="The official client application for the Waves platform"
+arch=('x86_64')
+url="https://wavesplatform.com/"
+license=('custom')
+depends=('gtk2' 'libxtst' 'libxss' 'gconf' 'nss' 'alsa-lib')
+source=("https://wavesplatform.com/files/WavesClient-${pkgver/_/-}.X-linux.deb")
+sha256sums=('625dec99daa10b5455c2ff25451bcb83a60cef00f8e5af7f36b422e15117d04c')
+
+package() {
+ bsdtar -O -xf "WavesClient-${pkgver/_/-}"*.deb data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/Waves Client/waves-client" "${pkgdir}/usr/bin/waves-client"
+} \ No newline at end of file