summarylogtreecommitdiffstats
diff options
context:
space:
mode:
authorLucas Candido de Souza Silva2019-11-19 01:39:14 -0300
committerLucas Candido de Souza Silva2019-11-19 01:44:01 -0300
commit867143a6bc5b21e3dabb12c0306bff92d0512e55 (patch)
treea84bb1a695bd41d1a4f21def4ccf87a9f4704770
downloadaur-867143a6bc5b21e3dabb12c0306bff92d0512e55.tar.gz
first release
-rw-r--r--.SRCINFO43
-rw-r--r--PKGBUILD25
2 files changed, 68 insertions, 0 deletions
diff --git a/.SRCINFO b/.SRCINFO
new file mode 100644
index 000000000000..82b44a61277c
--- /dev/null
+++ b/.SRCINFO
@@ -0,0 +1,43 @@
+pkgbase = waves-exchange
+ pkgdesc = Waves.Exchange is an exchange that combines the advantages of centralized and decentralized digital trading approaches
+ pkgver = 1.0.0
+ pkgrel = 1
+ url = https://waves.exchange
+ arch = x86_64
+ license = MIT
+ depends = alsa-lib
+ depends = atk
+ depends = at-spi2-atk
+ depends = at-spi2-core
+ depends = cairo
+ depends = dbus
+ depends = desktop-file-utils
+ depends = discord
+ depends = expat
+ depends = gconf
+ depends = gdk-pixbuf2
+ depends = glib2
+ depends = gtk3
+ depends = hicolor-icon-theme
+ depends = libappindicator-gtk2
+ depends = libcups
+ depends = libnotify
+ depends = libutil-linux
+ depends = libx11
+ depends = libxcb
+ depends = libxcomposite
+ depends = libxcursor
+ depends = libxdamage
+ depends = libxext
+ depends = libxfixes
+ depends = libxi
+ depends = libxrandr
+ depends = libxrender
+ depends = libxss
+ depends = libxtst
+ depends = nspr
+ depends = nss
+ depends = pango
+
+pkgname = waves-exchange
+
diff --git a/PKGBUILD b/PKGBUILD
new file mode 100644
index 000000000000..470222984696
--- /dev/null
+++ b/PKGBUILD
@@ -0,0 +1,25 @@
+# Maintainer Lucas Silva <lcdss[at]live[dot]com>
+
+pkgbase=waves-exchange
+pkgname=waves-exchange
+pkgver=1.0.0
+pkgrel=1
+pkgdesc="Waves.Exchange is an exchange that combines the advantages of centralized and decentralized digital trading approaches"
+url="https://waves.exchange"
+license=('MIT')
+_source=("https://waves.exchange/files/Waves.Exchange.deb")
+arch=('x86_64')
+_md5sums=(
+ '1867cef5e7098d6bdcd98944f38938ff'
+)
+depends=(
+ alsa-lib atk at-spi2-atk at-spi2-core cairo dbus desktop-file-utils discord expat gconf gdk-pixbuf2 glib2 gtk3 hicolor-icon-theme libappindicator-gtk2 libcups libnotify libutil-linux libx11 libxcb libxcomposite libxcursor libxdamage libxext libxfixes libxi libxrandr libxrender libxss libxtst nspr nss pango
+)
+
+package() {
+ bsdtar -O -xf Waves.Exchange.deb data.tar.xz | bsdtar -C "${pkgdir}" -xJf -
+ find "${pkgdir}" -type d -exec chmod 755 {} +
+
+ mkdir -p "$pkgdir/usr/bin"
+ ln -s "/opt/Waves.Exchange/waves-exchange" "${pkgdir}/usr/bin/waves-exchange"
+}